[Solved] Unbricking Netgear GS750E

This is great progress :smiley:

The last part of the installation instruction...

And then flash the -sysupgrade.bin file from OpenWrt.

means doing it on the command line as well.
The web interface (LuCI) is not included in the initramfs image.

https://openwrt.org/docs/guide-user/installation/sysupgrade.cli#command-line_instructions

First you transfer the ...-sysupgrade.bin image via SCP to your router's /tmp folder.
You can use WinSCP for that, if you are on Windows:
https://openwrt.org/docs/guide-quick-start/sshadministration#winscp

Then use the sysupgrade -v command on the router to flash it.

Thanks for helping me to be at this step !

I agree if my switch have network access. :frowning: But that not the case. My laptop have ip 192.168.1.234 and I'm unable to ping or scp or ssh 192.168.1.1. The same in other way, my switch is unable to ping my laptop.

Switch is directly connected to my laptop.

I already tried to restart my computer and my switch without success. :frowning:

I don't know what to do. :cry:

might need to install a snapshot image, because of https://github.com/openwrt/openwrt/pull/13579

2 Likes

Thanks, it works well with the snapshot version !

But, their is no web interface on snapshot ? I'm unable to reach it. SSH is ok.

Thanks.

1 Like

use https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=realtek%2Frtl839x&id=netgear_gs750e and click request build.

get the generated sysupgrade image, and upgrade your current openwrt using the new image.

or, if your switch got internet access, execute opkg update; opkg install luci.

1 Like

Good catch!

You forgot to mention to add luci-ssl to the list of packages in the Customize installed packages... drop down :wink:

And then request build.

There are differences in using snapshot builds:
https://openwrt.org/releases/snapshot#main_differences_of_buildbot_snapshots_vs_official_stable_releases

Thanks all for your help, my switch is alive now with OpenWRT !

To resume what I have done with your precious help (can be usefull for other people).

After connecting to the serial port with a special adapter (be carefull of the voltage :wink: , 3.3V for the GS750E), I started the kernel image from a snapshot version (in my case, but for other people, the last stable image can be ok).

rtk network on;
setenv serverip 192.168.1.234;
tftpboot 0x8f000000 openwrt-realtek-rtl839x-netgear_gs750e-initramfs-kernel.bin;
bootm;

Then, I uploaded the sysupgrade image to the switch (as I have network now :slight_smile: ). And then, perform the upgrade.

sysupgrade -v /tmp/openwrt-realtek-rtl839x-netgear_gs750e-squashfs-sysupgrade.bin

I had to change default IP of the switch by updating file /etc/config/network in order to match my subnet.

I also added a default gateway and DNS server.

config interface 'lan'
        option device 'switch.1'
        option proto 'static'
        option ipaddr '192.168.1.5'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '8.8.8.8'
        option ip6assign '60'

Then, I was able to install the GUI as you say.

opkg update
opkg install luci luci-ssl

And tadam !

Thanks again for your help. I have another GS750E to migrate but, now, I know how to save it in case of a crash. :smiley:

Bye.

2 Likes

@frollic, do you know, if a stable release can be pulled for a specific device? Has it been done before?
If I understand it correctly, 23.05.3 is essentially broken for this device, with the switch not working.

@sdewarle this would be a good opportunity to test, if any of the previous 23.05.x stable releases work on this switch.

Stopping new image generation has been done before, but not going backwards, AFAIK.

I'd expect all 23.05 releases to be affected.

Hm, it must have worked at some point.
At least when the support was added.
Iβ€˜m curious. Gonna check the git history later…

I took the liberty of creating a data entry in the ToH for this, so people would at least find the link with the git commit and the install instructions.
https://openwrt.org/toh/hwdata/netgear/netgear_gs750e

Now I would adjust it to support in snapshots only,
unless we can confirm any of the previous versions as working.

1 Like

Good idea, flagging it as snapshots only.

@sdewarle try the 23.05-RCs too, they ship with the webui.

They're all available via https://firmware-selector.openwrt.org/

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.