[SOLVED] Unbrick TPLink WR841N v11

#1

Hello

I've been running this router on dd-wrt for several years now. I wanted to try out OpenWRT, and was following this article - https://oldwiki.archive.openwrt.org/toh/tp-link/tl-wr841nd

However, upon flashing the recommended firmware, the router became unresponsive, and would not assign a LAN address. After several 30-30-30 resets, I tried the tftp unbrick process recommended. No firmware appears to have been installed, but now, the router does not even boot fully. If I power it on and hold down the WPS button, the lock LED stays lit, and no activity occurs in TFTP. If I let go, the power LED comes on and stays on, no other activity. Manually setting an IP address of 192.168.0.66 and scanning wireshark shows no router activity.

I've purchased a Serial TTL adapter and soldered pins in the appropriate places, but I get no activity in the console. Is there anything else I can try, or is this router well and truly dead?

Thanks
Michael

#2

Welcome.

For your info, the page you mentioned is the old Wiki, and isn't maintained. I am not sure what version you you're to flash.

This is the current page for the device https://openwrt.org/toh/tp-link/tl-wr841nd. A quick look suggests the content is very similar (which is expected, as it's an old device), but it wouldn't harm if you have a look there and see if it adds anything.

#3

If the "lock" (WPS) LED comes on when you boot with the reset button held down, this should be TFTP recovery. Note that to run a TFTP server on Windows you have to turn the windows firewall off.

On this model there is a missing resistor which prevents the serial port from receiving anything from the PC. You need to solder a small wire across the two pads for R23 or if you're really good, install a small resistor there of maybe 47 ohms.

#4

Thanks for the info. In TFTP mode, should it be showing some type of LAN activity? I will try turning the firewall off entirely, I've only added exceptions so far.

I am not that good =) I will try jumping R23 though

#5

Ok! Using Windows 7 and totally disabling the firewall did the trick. Thanks for the assist!

#6

@brewer-michael If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:
grafik

1 Like