[SOLVED] Unable to obtain IPv6 DHCPv6 Prefix Delegation over macvlan interface

ISP: AT&T Fiber in U.S.A
ISP Provided Gateway: Pace 5268ac
Router: Netgear R7800 running OpenWrt 22.03-SNAPSHOT r19235-d0965dc174 / LuCI openwrt-22.03 branch git-22.083.69105-af8e91c

I tried setting up a macvlan interface to request separate IPv6 /64 Prefix from the AT&T Pace 5268ac Gateway. However I am getting the following odhcp6c error:

daemon.err odhcp6c[21313]: Failed to send RS (Address not available)
daemon.err odhcp6c[21313]: Failed to send SOLICIT message to ff02::1:2 (Address not available)

daemon.err odhcp6c[21528]: Failed to send RS (Address not available)
daemon.err odhcp6c[21528]: Failed to send SOLICIT message to ff02::1:2 (Address not available)
daemon.err odhcp6c[21528]: Failed to send SOLICIT message to ff02::1:2 (Address not available)

Part of /etc/config/network (WAN interface is eth0, no vlan like eth0.1 or eth0.2)

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '5 0'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 2 3 4 6t'

config switch_port
        option port '0'
        option pvid '1'

config device 'eth0'
        option name 'eth0'
        option mtu '1500'
        option mtu6 '1500'

config device 'vwan1'
        option name 'vwan1'
        option type 'macvlan'
        option ifname 'eth0'
        option macaddr '3C:37:86:24:52:5D'
        option mtu '1500'
        option mtu6 '1500'
        option mode 'private'

config device 'vwan2'
        option name 'vwan2'
        option type 'macvlan'
        option ifname 'eth0'
        option macaddr '3C:37:86:24:52:5E'
        option mtu '1500'
        option mtu6 '1500'
        option mode 'private'

config interface 'wan6_1'
        option device 'vwan1'
        option proto 'dhcpv6'
        option reqaddress 'none'
        option reqprefix '64'
        option peerdns '0'

config interface 'wan6_2'
        option device 'vwan2'
        option proto 'dhcpv6'
        option reqaddress 'none'
        option reqprefix '64'
        option peerdns '0'

Part of /etc/config/firewall

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6_1'
        list network 'wan6_2'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option family 'ipv6'
        option target 'ACCEPT'
        list src_ip 'fc00::/6'
        option src_port '546-547'
        list dest_ip 'fc00::/6'
        option dest_port '546-547'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

"ip addr show" output:

16: vwan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 3c:37:86:24:52:5d brd ff:ff:ff:ff:ff:ff
    inet6 fe80::3e37:86ff:fe24:525d/64 scope link
       valid_lft forever preferred_lft forever
17: vwan2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 3c:37:86:24:52:5e brd ff:ff:ff:ff:ff:ff
    inet6 fe80::3e37:86ff:fe24:525e/64 scope link
       valid_lft forever preferred_lft forever

Can anyone guide me on this? Thanks in advance.

I solved this by adding the macvlan layer-2 devices ("vwan1" and "vwan2") directly to /etc/config/firewall and restarting "network" and "firewall" (firewall4 / nftables):

Part of /etc/config/firewall

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list network 'wan'
	list network 'wan6_1'
	list network 'wan6_2'
	list device 'eth0'
	list device 'vwan1'
	list device 'vwan2'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.