[SOLVED] Unable to connect to the Internet using WiFi on the latest 18.06.2 snapshot on TP-Link 1043Nv5

I've been trying to solve this issue for a few hours now by trying everything I can think of but I can't figure out what to do.

I've been using an older snapshot of 18.06.1 on my TP-Link 1043Nv5 and everything was working fine until today when I came home and found that WiFi Internet wasn't working although wired Internet is working fine. I tried reverting back to 20Mhz, adding option noscan 1, changing channels and transmit power but nothing worked. I also upgraded to the latest 18.06.2 snapshot but I still get the same issue. The WiFi works and I'm able to sync data between my phone and desktop which are in Wireless LAN but the Internet doesn't work on my phone when it's connected to WiFi.

Now, I've simply generated a default config by using wifi config but my WiFi still doesn't work. I keep getting the following lines in the system log -

user.notice mac80211: Failed command: iw phy phy0 set antenna all all
kern.info kernel: [ 1539.854125] IPv6: ADDRCONF(NETDEV_UP): tmp.radio0: link is not ready
kern.info kernel: [ 1539.939877] IPv6: ADDRCONF(NETDEV_UP): tmp.radio0: link is not ready
daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
kern.info kernel: [ 1540.441629] br-lan: port 2(wlan0) entered blocking state
kern.info kernel: [ 1540.447129] br-lan: port 2(wlan0) entered disabled state
kern.info kernel: [ 1540.452989] device wlan0 entered promiscuous mode
daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
daemon.err hostapd: Using interface wlan0 with hwaddr 70:70:70:70:70:16 and ssid "mywifi102"
kern.info kernel: [ 1541.081988] br-lan: port 2(wlan0) entered blocking state
kern.info kernel: [ 1541.087506] br-lan: port 2(wlan0) entered forwarding state
daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->ENABLED
daemon.notice hostapd: wlan0: AP-ENABLED
daemon.notice netifd: Network device 'wlan0' link is up
daemon.notice vnstatd[2098]: Interface "wlan0" enabled.
kern.info kernel: [ 1690.490996] device wlan0 left promiscuous mode
kern.info kernel: [ 1690.495760] br-lan: port 2(wlan0) entered disabled state
daemon.notice hostapd: wlan0: interface state ENABLED->DISABLED
daemon.notice hostapd: wlan0: AP-DISABLED
daemon.notice hostapd: wlan0: CTRL-EVENT-TERMINATING
daemon.notice hostapd: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
daemon.notice hostapd: nl80211: Failed to remove interface wlan0 from bridge br-lan: Invalid argument
user.notice mac80211: Failed command: iw phy phy0 set antenna all all
daemon.err hostapd: Configuration file: /var/run/hostapd-phy0.conf
kern.info kernel: [ 1691.293753] br-lan: port 2(wlan0) entered blocking state
kern.info kernel: [ 1691.299306] br-lan: port 2(wlan0) entered disabled state
kern.info kernel: [ 1691.305104] device wlan0 entered promiscuous mode
kern.info kernel: [ 1691.310071] br-lan: port 2(wlan0) entered blocking state
kern.info kernel: [ 1691.315576] br-lan: port 2(wlan0) entered forwarding state
daemon.err hostapd: Using interface wlan0 with hwaddr 70:70:70:70:70:16 and ssid "OpenWrt"
daemon.notice hostapd: wlan0: interface state UNINITIALIZED->ENABLED
daemon.notice hostapd: wlan0: AP-ENABLED
daemon.notice netifd: Network device 'wlan0' link is up

The /etc/config/network file is

root@sun:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option dns '1.1.1.1 9.9.9.9'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '70:70:70:70:70:16'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'pppoe'
        option username 'ayushagarwal'
        option password 'ayushagarwal'
        option ipv6 '0'
        option keepalive '0'
        option peerdns '0'
        option dns '1.1.1.1 9.9.9.9'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '70:70:70:70:70:b7'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config interface 'guest'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'

Any ideas please?

At first thought, the problem is likely in your wireless config or drivers/firmware, based on your logs showing the wireless interface coming up, then failing seconds later. Also, is 5 GHz and DFS involved?

Nope, TP-Link 1043N v5 doesn't have 5GHz or DFS.

Here's the wireless config right now ...

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'abcd4321'

about drivers/firmware ...

I was using a 18.06.1 snapshot since January 2019 without any issues and the same snapshot started giving me problems today without any modifications or changes done on my end. I thought it might be a bug due to outdated software and so I upgraded to the latest 18.06.2 snapshot but the WiFi issue still persists.

That, unfortunately, hints at the possibility of hardware failure. That wouldn't surprise me on a 5-year-old device, but the v5 is, according to WikiDevi, likely only a year or two old.

Is it stable with no clients connected?

Is it stable with no clients connected?

You mean the wired connection? Yeah, everything works as expected except the WiFi.

The Internet on my phone does work for about 30 seconds after the initial connection to the WiFi but then it stops working.

Without any wireless clients connected. Does the wireless "stay up" solidly without anyone connecting to it?

Yeah, it does. The wireless interface stays up when no clients are connected to it.

I'm also able to sync data between my desktop and phone using Syncthing and CalDav/CardDav when WiFi is connected. It's just that the Internet doesn't work. My phone shows "Connected, No Internet".

I missed that from your earlier posts. It might be worth editing the title so others with familiarity with the hardware can more easily provide insight.

1 Like

I missed that from your earlier posts. It might be worth editing the title so others with familiarity with the hardware can more easily provide insight.

Done. Thanks for pointing that out.

1 Like

It's always a good idea to set your country code. Also set legacy_rates to 0 on 2.4 radios.

Since you're just running a basic AP here, test using stock firmware to see if there is hardware failure.

1 Like

It's always a good idea to set your country code. Also set legacy_rates to 0 on 2.4 radios.

Done. I've set my country code and disabled the option Allow legacy 802.11b rates in LuCI. After reloading, the Internet still doesn't work.

test using stock firmware to see if there is hardware failure.

How do I do that?

Check the device wiki for how to flash back to stock. Late model TP-Link should have TFTP recovery. Then configure the stock firmware for your ISP and set up wifi and see if it is usable.

Oh, you mean the TP-Link firmware. Ok, I'll do that and see how it goes. Thanks for the suggestions.

I did a factory reset and enabled the WiFi after a bare bones configuration and the Internet works. I have no idea what went wrong in the config that I had earlier ... I didn't even change anything and it was working fine before. :confused:

I'll have to configure everything again step by step ... firewall, port forwards, APs. Oh well ...

Thanks for the help @jeff and @mk24.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.