[Solved] Ubiquiti U6 Lite: Wi-Fi as WAN not working on ax radio: "DHCP packet received on wlan1 which has no address"

I'm running 21.02.6 on a Ubuqiuti U6 Lite. The device is in completely out-of-box defaults trying to use Wi-Fi as WAN. Simple config done through LuCI by scanning and connecting through the UI.

I see successful WPA supplicant milestones through negotiation and sustained valid RX/TX rates, but no IP is acquired via DHCP. I get the following in logread:

daemon.warn dnsmasq-dhcp[8198]: DHCP packet received on wlan1 which has no address

This only seems to be when connecting to an AX access point. AC on 5GHz works just fine. As expected, the other radio (2.4 GHz) works as intended through the same process. Below are the configs:


/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '48'
        option band '5g'
        option htmode 'HE80'
        option cell_density '0'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid '<redacted>'
        option encryption 'psk2'
        option key '<redacted>'


/etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd3a:1486:e4bc::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
        option proto 'dhcp'

config device
        option name 'wlan1'
        option ipv6 '0'


/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option force '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

I'm grateful for any help I can get!

Does the wifi connect but not obtain an IP, or does it not connect at all?

Remove this. Don't refer to wlan networks in /etc/config/network. Wifi interfaces are attached to a network with option network in /etc/config/wireless. The name of the interface may vary.

Since wwan is a dhcp client not a server, add an ignore block for wwan like the one for wan. This will prevent dnsmasq from listening to wwan.

Set your country code on the radios, the same country on both radios even if one is disabled.

Make sure you've added wwan to the wan firewall zone.

@mk24 Thank you for your thoughts!

UPDATE: According to the datasheet, the U6 Lite doesn't not support 160MHz. iw does list 160Mhz as a capability, however. Leaving data below anyway.

I cleaned up the configs per and checked everything per your recommendations. All looks good and behavior was the same. Did some additional testing and things get a little weird...

Broadly, this seems like an issue when trying to connect to 160Mhz bandwidth networks. Beyond that, I'm not sure what's going on.

The AP I was connecting to in my original question (U6 Pro, running factory Ubiquity software) was configured for 160Mhz. I changed it to 80 and everything works as expected in terms of connecting to it from the U6 lite, acquiring an IP address, and holding the connection. Again, switched it back to 160Mhz and no dice, same as before.

logread from that period

Wed May  3 16:38:26 2023 daemon.notice wpa_supplicant[1472]: wlan1: SME: Trying to authenticate with 60:22:32:16:fb:5f (SSID='<redacted>' freq=5180 MHz)
Wed May  3 16:38:26 2023 kern.info kernel: [  375.176696] wlan1: authenticate with 60:22:32:16:fb:5f
Wed May  3 16:38:26 2023 kern.info kernel: [  375.212940] wlan1: send auth to 60:22:32:16:fb:5f (try 1/3)
Wed May  3 16:38:26 2023 kern.info kernel: [  375.223079] wlan1: authenticated
Wed May  3 16:38:26 2023 daemon.notice wpa_supplicant[1472]: wlan1: Trying to associate with 60:22:32:16:fb:5f (SSID='<redacted>' freq=5180 MHz)
Wed May  3 16:38:26 2023 kern.info kernel: [  375.233667] wlan1: associate with 60:22:32:16:fb:5f (try 1/3)
Wed May  3 16:38:26 2023 daemon.notice netifd: Network device 'wlan1' link is up
Wed May  3 16:38:26 2023 daemon.notice netifd: Interface 'wwan' has link connectivity
Wed May  3 16:38:26 2023 daemon.notice netifd: Interface 'wwan' is setting up now
Wed May  3 16:38:26 2023 daemon.notice wpa_supplicant[1472]: wlan1: Associated with 60:22:32:16:fb:5f
Wed May  3 16:38:26 2023 kern.info kernel: [  375.247329] wlan1: RX AssocResp from 60:22:32:16:fb:5f (capab=0x1511 status=0 aid=13)
Wed May  3 16:38:26 2023 kern.info kernel: [  375.257002] wlan1: associated
Wed May  3 16:38:26 2023 daemon.notice wpa_supplicant[1472]: wlan1: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Wed May  3 16:38:26 2023 daemon.notice wpa_supplicant[1472]: wlan1: Unknown event 37
Wed May  3 16:38:26 2023 kern.debug kernel: [  375.314406] wlan1: Limiting TX power to 27 (30 - 3) dBm as advertised by 60:22:32:16:fb:5f
Wed May  3 16:38:26 2023 daemon.notice netifd: wwan (3891): udhcpc: started, v1.35.0
Wed May  3 16:38:26 2023 daemon.notice wpa_supplicant[1472]: wlan1: WPA: Key negotiation completed with 60:22:32:16:fb:5f [PTK=CCMP GTK=CCMP]
Wed May  3 16:38:26 2023 daemon.notice wpa_supplicant[1472]: wlan1: CTRL-EVENT-CONNECTED - Connection to 60:22:32:16:fb:5f completed [id=0 id_str=]
Wed May  3 16:38:26 2023 kern.info kernel: [  375.355272] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Wed May  3 16:38:26 2023 daemon.notice wpa_supplicant[1472]: wlan1: Unknown event 37
Wed May  3 16:38:26 2023 daemon.notice netifd: wwan (3891): udhcpc: broadcasting discover

wlan1: Unknown event 37

This event code seems to be a recurring message when using 160Mhz in either direction.

Even when changing the channel to 100, as there seems to be reg db discrepency for that bandwidth.

iw reg get (for the U6 lite)

global
country US: DFS-FCC
        (902 - 904 @ 2), (N/A, 30), (N/A)
        (904 - 920 @ 16), (N/A, 30), (N/A)
        (920 - 928 @ 8), (N/A, 30), (N/A)
        (2400 - 2472 @ 40), (N/A, 30), (N/A)
        (5150 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW
        (5250 - 5350 @ 80), (N/A, 24), (0 ms), DFS, AUTO-BW
        (5470 - 5730 @ 160), (N/A, 24), (0 ms), DFS
        (5730 - 5850 @ 80), (N/A, 30), (N/A), AUTO-BW
        (5850 - 5895 @ 40), (N/A, 27), (N/A), NO-OUTDOOR, AUTO-BW, PASSIVE-SCAN
        (5925 - 7125 @ 320), (N/A, 12), (N/A), NO-OUTDOOR, PASSIVE-SCAN
        (57240 - 71000 @ 2160), (N/A, 40), (N/A)

I spun up a second U6 Lite running OpenWRT as another 802.11ax AP to test. Everything worked fine on 80Mhz when connecting to it from the original U6 Lite. Put it into 160Mhz on channel 36 like the other device and got a different behavior. The U6 Lite in client mode actually does connect to the AP and gets an IP but the data rates seemed to be locked at 6 Mbps for some reason.

RX Rate / TX Rate

6.0 Mbit/s, 20 MHz
6.0 Mbit/s, 20 MHz

I don't see anything weird in the logs.

*edit: my Macbook won't get an IP in this mode while the U6 Lite does.

I'll have a 3rd non-ubiquity 802.11ax capably piece of hardware as another AP to do some additional testing on by the end of the day, but I'd appreciate any thoughts in the meantime.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.