[Solved] UART on Mikrotik RBM11G

Hi everyone!
I have a problem with Mikrotik RBM11G. This hardware has uart-pins for console but connection to it give no any data. I'v tried to connect via rs232, cp2102 и pl2303 - no result.
Internet forums say that to connect to uart-pins I must have a some special RouterBOOT image that not for public usage. But in same time exists topic with successful installation Link. I don't understand what to do

No answers sorry, I can only offer suggestions/ideas.

Try reversing the tx/rx pins on your uart. Some uart cable manufacturers label them based on what they are vs what they should connect from/to.

If you have another device with uart serial headers, try soldering the pin out on that and test the uart cable on there. (Could be misconfiguration on your terminal software, or faulty cable)

Double check your terminal software is using the correct settings for the device (eg 115200n8r (<baud><parity><bits><flow>) check whats applicable for your device )

Soldering. If your soldering skills are anything like mine :roll_eyes: , double check (eg with a multimeter) that the pads you’ve soldered definitely have contact at the other end of the cable.

The mention of special firmware in relation to this device could mean the vendor has crippled the serial console intentionally... if that’s the case , it’s probably going to be near impossible to solve. (And in my book , a valid reason to vote with your wallet and not purchase from this vendor again)

Edit: added point about checking soldering.

Adding to that great list, the adapter voltage levels have to be compatible with the SoC's (an RS232 or 5V adapter can fry a 3.3 V SoC) and that V+ should not be connected.

You need a 3.3v ttl adapter like this: https://cdn.instructables.com/F0L/DZH2/HFD1F0NF/F0LDZH2HFD1F0NF.LARGE.jpg

You can find correct pinout here:

If what you want is to install openwrt you can do it without ttl, simply use tftp server and boot the board in netboot mode(hold reset button for cca 30 sec when powering on)

use this file for tftpboot: http://downloads.openwrt.org/releases/18.06.2/targets/ramips/mt7621/openwrt-18.06.2-ramips-mt7621-mikrotik_rbm33g-initramfs-kernel.bin
than do a sysupgrede with this file :http://downloads.openwrt.org/releases/18.06.2/targets/ramips/mt7621/openwrt-18.06.2-ramips-mt7621-mikrotik_rbm33g-squashfs-sysupgrade.bin


Thanks everyone for your suggestions!
@Sparks yes, pins was checked and cable is ok
@subixonfire now it works after using 3.3v ttl + already compiled image. Thank you. But it didn't work with self-compiled image. Do I need to select some special options in kernel_menuconfig to make uart work?

Now I successfully see uart output but I have new problem - when I try to mount mtd partitions I get:

root@OpenWrt:/# mount -o ro /dev/mtdblock1 /mnt/kernel/
mount: mounting /dev/mtdblock1 on /mnt/kernel/ failed: Invalid argument

In mtd table I see all partitions but can't mount it

1 Like

Good stuff.
To keep the forum tidy, and easy for others to find info in future when searching, can you raise the new issue as a new thread.


Yes, I think it's good idea

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.