[Solved]Troubles with ISP Bridging as a dumb AP

My ISP modem/router provides DHCP for the bridged wireless access point they gave us. I'm trying to configure my WRT3200ACM to act as a Bridged AP as well, passing through DHCP from my ISP's modem to my wireless and wired clients.

Been fiddling with https://openwrt.org/docs/guide-user/network/wifi/bridgedap but can't get things to work quite right.

Previous /etc/config/network before attempting to bridge:

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'totally fake mac'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp' -- gets a 10.88.111.0/24 address from my ISP device with a gateway of 10.88.111.254 
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '208.67.220.220'
	list dns '9.9.9.9'

After attempting to bridge, I would connect a WRT3200 LAN port to my ISPs modem, but couldn't get the connectivity I wanted. Tried this in my network config and turned off dnsmasq, but no connectivity as I desired:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
        option type bridge
	option proto 'static'
	option ipaddr '10.88.111.252' 
	option netmask '255.255.255.0'
        option gateway '10.88.111.254'
        option dns '10.88.111.254'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'totally fake mac'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp' -- Left untouched so I can recover/troubleshoot 
	option peerdns '0'
	list dns '1.1.1.1'
	list dns '208.67.220.220'
	list dns '9.9.9.9'

In a visual form, here's both my current and desired configuration. Any help to achieve the desired config would be really appreciated!

all clients should receive an address in the 10.88.111.x/24 class

it would seem you want to have a single LAN, so the guide below should suffice.

What you want is to convert the router to a dumbAP.

2 Likes

Thanks @ncompact. I had read that before and foolishly thought it wouldn't apply. Worked absolutely fine.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.