[Solved] Trouble installing LEDE on PC Engines APU2C4 running Ubuntu

Hi,

I have a PC Engines APU2C4 with Ubuntu installed on its internal hard drive.
Following the Installation instructions on OpenWRT Wiki, I used unetbootin to create a bootable USB disk with a ganzipped x86 version of the 17.01.4, ext4 image (image link found on apu2c4's LEDE page)

Having the USB flash disk plugged, unetbootin loads and then I select LEDE.

The installation gets stuck at some point and think it has to do with my formatting of the hard disk.

Does it need an ext4 partition? Is that what holds it? Should I create a partition and then it will work?

Thanks!


[    0.000000] Linux version 4.4.92 (buildbot@debian8) (gcc version 5.4.0 (LEDE                                                                                                                                                              GCC 5.4.0 r3560-79f57e4) ) #0 SMP Tue Oct 17 17:46:20 2017
[    0.000000] Command line: BOOT_IMAGE=/boot/vmlinuz root=PARTUUID=b3ade79d-02                                                                                                                                                              rootfstype=ext4 rootwait console=tty0 console=ttyS0,115200n8 noinitrd
[    0.000000] x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
[    0.000000] x86/fpu: Supporting XSAVE feature 0x01: 'x87 floating point regis                                                                                                                                                             ters'

...

[    2.840699] scsi 2:0:0:0: Direct-Access     SanDisk  Cruzer Edge      1.26 PQ                                                                                                                                                             
: 0 ANSI: 6
[    2.849646] sd 2:0:0:0: [sdb] 15633408 512-byte logical blocks: (8.00 GB/7.45                                                                                                                                                              
GiB)
[    2.858182] sd 2:0:0:0: [sdb] Write Protect is off
[    2.863573] sd 2:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doe                                                                                                                                                             
sn't support DPO or FUA
[    2.876691]  sdb: sdb1
[    2.881016] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[    3.009921] clocksource: Switched to clocksource tsc

Loading Ubuntu and checking for my current partitions:

root@pcengines:~$ lsblk
NAME                     MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda                        8:0    0 14.9G  0 disk
└─sda1                     8:1    0 14.9G  0 part
  ├─pcengines--vg-root   253:0    0 10.9G  0 lvm  /
  └─pcengines--vg-swap_1 253:1    0    4G  0 lvm  [SWAP]

There is no 'installer'. You unpacked the root FS to your USB stick. You probably just need to hit Enter to get a prompt.

I'm curious as to why you'd need unetbootin? If Ubuntu boots already, that means your device has a bootloader. I know the APU2 e.g. comes with coreboot, although booting from external media would be disabled once you had internal storage attached. Is unetbootin intended to work around that?

1 Like

Your answer was correct.

So, I did the following things that worked. I now have a functioning LEDE-based APU2C4.

  1. I had already setup a USB-to-RS232 cable connected to PC Engines and to USB port of my laptop. Used Putty for all the commands below.
  2. Installed TinyCore on the USB stick using my Windows laptop and copied over the combined-ext4.img.gz LEDE firmware on the USB stick
  3. Booted apu2c4 with TinyCore on the USB stick, hit FN+F10, selected #1 and then through TinyCore used the 'fdisk' command to re-format the ssd (/dev/sda)
  4. Ran then the command to gunzip LEDE firmware onto the SSD:
    zcat lede-17.01.4-x86-64-combined-ext4.img.gz | dd of=/dev/sda bs=16k
    (see Installation)
  5. Rebooted without the USB and 'boom!'

  1. Then connected to the internet the ETH port closest to the serial cable. While using Putty via serial, I installed SSH server and luci
  2. Then connected my laptop directly to the middle LAN ETH port and was able to get IP from DHCP and access the luci interface on http://192.168.1.1

Some useful resources I found by searching around the web:
a. Searching on the PC Engines forum for OpenWRT related software topics

1 Like