[SOLVED] Trendnet TEW-714TRU installation without factory.bin

I have a TEW-714TRU travel router and saw it was became supported a year or so ago and exists in the 17.01 releases. There doesn't seem to be a -factory.bin image for it, only an initramfs-kernel.bin and -sysupgrade.bin.
The documentation suggests checking the device info page for forum links or installation hints but I came up empty here too. Did I miss something obvious about this device?
I was going to take a shot in the dark and just try upgrading from the OEM firmware upgrade page using the sysupgrade.bin image available but thought I'd seek some advice before I ruin this thing.

These links:




don't work???

Usually, there are only 2 images:

  • one to flash from OEM to OpenWRT; and
  • sysupgrade

I would try the first link, it otherwise it likely has no reason to exist.

The links are functional but the installation documentation is pretty explicit that sysupgrade images are only for use when upgrading an existing openwrt install and that the lack of factory image means I require a special installation procedure. The troubleshooting section there is what led me here to double check before I get myself in trouble.

If you can only find a LEDE “sysupgrade.bin” file, but no “factory.bin” firmware file, a device-specific custom installation procedure is required (Assuming your device does not already have an older LEDE or OpenWrt version installed). You can find custom installation instructions at the following locations:

  1. On the LEDE Techdata page of the device, check the fields “LEDE Forum Topic URL” and “Comment” for any external links or comments regarding custom installation procedures.
  2. Look for the corresponding device page in the older OpenWrt wiki, if that has any custom installation descriptions (Eventually older OpenWrt info will be migrated to the LEDE tech data pages).
  3. Search the LEDE forum for existing discussion threads about the device name or open a new topic in the LEDE forum, asking for instructions.

It sounds like the initramfs-kernel image is intended for testing based on this Q&A since it doesn't persist configuration.

I'll give the sysupgrade image a try tonight if someone with experience with this device doesn't chime in before then. If it works this thread will at least satisfy the #3 troubleshooting step for the next guy.

1 Like

Can the device be accessed via TFTP?

If so, the first BIN may be to boot, and the sysupgrade BIN would flash it.

The easy path was unsuccessful, the OEM GUI accepts the file but it immediately goes to the "router is rebooting" page without actually flashing or even rebooting like it would with an OEM firmware image.
Also tried flashing back to the earliest available firmware (1.01) and it accepted that, but no improvement trying to flash either the kernel or sysupgrade images then.
Other Trendnet routers with similar SoC have notes on their device pages that they can simply be upgraded using the sysupgrade image directly from the OEM GUI but no such luck here.
It does have a telnet server enabled by default but I haven't figured out the username and password. admin/admin don't work (default for other Trendnet products) and the username/password printed on the router label (admin/some random letters and symbols) don't work either. I'll explore if TFTP is a possibility.

I ended up having to go back to 17.01.3 and was able to successfully flash the initramfs-kernel from the OEM GUI. This got me read-only function.
Once I was into LuCI I went to the firmware upgrade and attempted to flash the 17.01.3 sysupgrade to get a persistent configuration. This failed with an error that the image was not for my device. I also tried the 17.01.4 sysupgrade and got the same error.
Next I logged in via SSH and tried the sysupgrade from the shell. It immediately terminated with the error:

device generic not supported
Supported devices tew-714tru

Perhaps these images are built with incorrect device settings and that's why I wasn't able to initially flash them.
Running out of patience, I forced the sysupgrade with -F and it completed the flash and rebooted to a working state. I've got the device running 17.01.4 now and everything seems to be working as it should.
Hopefully this helps someone else in the future with these dirt cheap travel routers.


Thanks for the write-up!

I've been tempted by them several times. (To the point of ordering one on Amazon, only to have the voice in the back of my head shout, "Why do you need another router??!!" and cancel the order.)

I'd enjoy reading on your experiences with it once you've had it running a while.

I initially bought this one to use in WISP mode on hotel wifi so I can use my Chromecast on hotel TVs (when the HDMI ports are accessible...) and it worked well out of the box for that.

I have a travel trailer that we take to campgrounds and some of those have public wifi as well. The trouble with those is the APs are usually so far away that the signal inside the camper is terrible so this device didn't have enough reach. I had an old Alfa AWUS036H with an external high gain antenna that I can now hook up to the USB port on this that will hopefully bring in the signal better.
Just had to add the kmod packages for it (some USB modules and rtl8187) and after a reboot it shows up in the wireless section like the internal radio. I can use it as the client for the public wifi and the internal radio as the AP for my private network.
I tested it with my home wifi and it's working so hopefully now I have a compact setup I can tuck away in one of the storage compartments for wifi in the woods.

Sorry to bump an old topic, but does anyone know the serial settings for the TEW-714TRU?

The only information I have found online is https://gist.github.com/johnp789/85bc60a1ac0835a249aed90052932243#file-tew-714tru-u-boot-environment-txt

but those settings give me nothing on my bootlooping TEW-714TRU, I get a red light, boot up buzz and then reboot

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.