[Solved]Transmission Won't Download Anything

I have tried various reboots of my router, Tp-Link TD-W8980 v1 running 18.06.1, and restarts of transmission but the problem is still there. After a small amount of download the torrent task fails without any error. It wont download further and just displays that downloaded amount is zero. Even if I resume it again, same situation follows.

I have mounted the USB drive already as extroot and it's working fine but somehow transmission thinks that there is no more space on the device. Although the drive is successfully mounted and has free space of more than 400 GBs.

Transmission config is as follows:

config transmission
	option enabled 			1
	option config_dir 		'/data/transmission-config'
	option config_overwrite 	'1'
	option user 			'transmission'
	option group 			'transmission'
	option mem_percentage 		10
	option nice 			10
	option alt_speed_down 		50
	option alt_speed_enabled 	false
	option alt_speed_time_begin  	540
	option alt_speed_time_day 	127
	option alt_speed_time_enabled 	false
	option alt_speed_time_end 	1020
	option alt_speed_up 		50
	option bind_address_ipv4 	''
	option bind_address_ipv6 	'::'
	option blocklist_enabled 	false
	option blocklist_url 		''
	option cache_size_mb 		2
	option dht_enabled 		true
	option download_dir 		'/data/torrent-downloads'
	option download_queue_enabled 	true
	option download_queue_size 	1
	option encryption 		1
	option idle_seeding_limit 	30
	option idle_seeding_limit_enabled false
	option incomplete_dir 		''
	option incomplete_dir_enabled 	false
	option lazy_bitfield_enabled 	true
	option lpd_enabled 		false
	option message_level 		1
	option peer_congestion_algorithm ''
	option peer_limit_global 	240
	option peer_limit_per_torrent 	60
	option peer_port 		58250
	option peer_port_random_high 	65535
	option peer_port_random_low 	49152
	option peer_port_random_on_start false
	option peer_socket_tos 		'default'
	option pex_enabled 		true
	option port_forwarding_enabled 	true
	option preallocation 		1
	option prefetch_enabled 	true
	option queue_stalled_enabled 	true
	option queue_stalled_minutes 	30
	option ratio_limit 		2.0000
	option ratio_limit_enabled 	false
	option rename_partial_files 	true
	option rpc_authentication_required false
	option rpc_bind_address 	''
	option rpc_enabled 		true
	option rpc_host_whitelist 	',192.168.1.*'
	option rpc_host_whitelist_enabled true
	option rpc_password 		''
	option rpc_port 		9091
	option rpc_url 			'/transmission/'
	option rpc_username 		''
	option rpc_whitelist 		',192.168.1.*'
	option rpc_whitelist_enabled 	true
	option scrape_paused_torrents_enabled true
	option script_torrent_done_enabled false
	option script_torrent_done_filename ''
	option seed_queue_enabled 	false
	option seed_queue_size 		2
	option speed_limit_down 	100
	option speed_limit_down_enabled true
	option speed_limit_up 		20
	option speed_limit_up_enabled 	true
	option start_added_torrents 	true
	option trash_original_torrent_files false
	option umask 			18
	option upload_slots_per_torrent 14
	option utp_enabled 		true
	option scrape_paused_torrents 	true
	option watch_dir_enabled 	false
	option watch_dir 		''

Now that I see it's downloading data to /root/Downloads/* but in the config I have set the location otherwise. What can I do to make it work?

After numerous attempts of restarting and pointing incomplete directory to USB has solved the issue. I also put in watch_dir but I have not create it in the USB just yet. But anyway it's downloading now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.