[Solved] TPlink TD-W8970

Yes loop back works. Its and FTDI RPi cable and they seem fairly reliable.

I'm getting to the stage where all I can think of is taking the solder off all three pins, and removing the header - then at least I can look at the board from the other side.
May well be best to ask expert at work - don't know if he can test the solder joint using magic ....

OK expert at work rapidly found my problem. Alas when removing the solder from the RX hole, the soldar sucker removed the pad as well as the solder (on the back of the board).

So what seems easiest now is to remove the heat sink on the CPU, and attacking an RX wire direct onto the chip. Hopefully its a quad flat pack package.

Can't believe I removed the pad, that stupidity for you. Must have applied too much heat or something ... sigh ...

It isn't, it's BGA instead.

Argh - so no way to attach to the other end of the track.

So only option is to try and find a way to remove the 3 pin header? Hard as even with solder wick/ sucker its hard to remove all solder. And that means unsoldering all three legs at the same time ...

Anyway if could remove it, then could use the pad on the top of the board I guess ...

not sure if you have looked at the pages

https://wiki.openwrt.org/toh/tp-link/td-w8970
https://wiki.openwrt.org/toh/tp-link/td-w8980

but they talk about shorting a pin to get into UART mode
maybe you connection is on but the mode is not enabled

Thank Lucky1. Thats for getting the xway cpu bootloader to go into uart mode.

In my case the uboot (and the kernel) that runs on top of it is fine, so I should be able to do a standard boot, and not force the cpu bootloader into a special mode.

uboot monitors the keyboard so, I should be able to interupt that.

Anyway, think over night, if I can remove the black pin holder, the pins will be individually mounted on the board. Then I can unsolder each one at at time. That should give access to the pads on the top of the board, and I can solder wires directly onto that.

Now how hard it is to remove the black pin holder remains to be seen ....

The trace leading to the RX pad seems to be placed on the top layer. You said the missing pad is on the back of the board (bottom layer)? In this case, I would leave the header pins in place, just remove some of the plastic and check the trace/pad on the top side for possible damage, then solder the RX pin to the top side pad.

1 Like

@mpa Yes that makes sense. How is easiest to remove the plastic? Wire snips?

Yes or side cutters

Chipped off the black plastic holding the pins together. Couldn't just do one side of the plastic - wire snips could only go from side to side, so it took off all the plastic. Alas this spread the legs slightly - should still be able to attach a USB-uart to them though.

And the pad on the top looks good. I'll take it into work tomorrow to check under the scope, and solder on the top.

At least this means won't have to take the pins out - which will be easier if I ever need the uart again ....

Hi there,

I get stuck flashing a w8970 rev1.2 with web hack.

At the moment as soon as I plug an ethernet cable, the light turns on but I can't get an IP.
I tried with static ip 192.168.1.10 with no result.

I have the serial pins available and using a TLL to usb chipset via putty I can open a serial console but I don't receive msg nor I can stop the boot pressing 't' several times
Probably as beginner I connected all 4 pins to the serial adaptor. after reading this thread I tried without the VCC but still nothing.

Any hint?

general consideration: does the Ethernet light means something if it switches on and off as soon as I plug or unplug the cable?

thanks a lot

I think you are using wrong values to connect to serial console. Read the documentation at Openwrt.org about serial consoles. Also note that you may need to connect TX and RX to different pins intermittently, for example TX on adapter -> RX on router and RX on adapter -> TX on router and GND to GND and don't connect VCC unless you want to risk your router turning into a crappy box. Look for the exact serial console values on the device page.

Thanks @ahmar16,

switching the TX and RX did help.

I tried to upload:

openwrt-18.06.1-lantiq-xrx200-tplink_tdw8970-squashfs-sysupgrade.bin

and this has been the msg on the serial console:

Retry count exceeded; starting again 8192 KiB EN25Q64 at 0:3 is now current device

I'm not sure I'm uploading the right one so far.

In the main page on the OpenWRT BOOTLOG

it is shown to upload:
openwrt-lantiq-xrx200-TDW8970-uImage-initramfs

What is the right step and where I can download files that are not listed in the Download page?

Thanks

PS: I found the openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade.image but still bigger than 4MB and same problem. On old post I read it is required to create image with initramfs support and I went lost even more

PPS: I found this tutorial on youtube where following the openwrt page upload the image without problem. This mean the problem is either on my router side or on my linux side.
When I upload the *.bin file, instead of ### I receive T T T. Does it means something?
I tried to upload the original TP firmware with same result.

hints?

thanks

Its normaly this simple: https://openwrt.org/toh/tp-link/td-w8970_v1#installation_using_serial

You just solder 3 or 4 pins (i always solder 4 pins - looks better for me). I have done this on a two digit number of devices. I never had any issues with falling off soldering pins ( @summers ). https://openwrt.org/toh/tp-link/td-w8970_v1#serial

Just copy the latest sysupgrade file from here https://downloads.openwrt.org/releases/18.06.1/targets/lantiq/xrx200/openwrt-18.06.1-lantiq-xrx200-tplink_tdw8970-squashfs-sysupgrade.bin to your tftp folder. But rename it! Name it something short. For example 8970.bin.
Then the command line looks like this: tftpboot 0x81000000 8970.bin

I recommend using minicom with flow control disabled and anything else default. https://openwrt.org/docs/guide-user/installation/generic.flashing.tftp?s[]=tftpd
Modern tftpd-hpa have its tftp directory set at /srv/tftp (not the named directory in the wiki). You can see the directory used when you run /etc/init.d/tftpd-hpa status .

For 8970 devices (without the terrible 5gh wifi chip) you take the image i linked above.
For 8980 and 9980 (with the terrible 5ghz non working chip) you take this image (or at later time any updated link) https://downloads.openwrt.org/releases/18.06.1/targets/lantiq/xrx200/openwrt-18.06.1-lantiq-xrx200-tplink_tdw8980-squashfs-sysupgrade.bin

Well you are still getting timeout when you try to upload the file through tftp. Try renaming the file as short as possible as @wgqoufsn suggested above and use the correct firmware file.

Hi there,

at the end I did manage to upload the ROM.
What I did and I can't confirm which of the 2 worked although I have a slight idea, is as follow:

  • On the server side I opened a tftp connection with the router

  • I changed the permission to the ROM file

I believe the second was the real solution. I should have think of it before.
I hope someone can learn from my mistake.

For your information the modem/router works as a charm now.

thanks to the OPENWRT group!!!!!

cheers

@gipsea If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

sorry, can't find the pencil....

No worries...it's because you're not the original poster.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.