[Solved] TP-Link WR841N v14.6 - UART question

Hello,

I am trying to gain root access to a TP-Link WR841N v14.6. I am using a Serial to USB converter, and doing GND-GND, RX-TX, TX-RX, it's all 3.3v, at 15200 baud rate. I am able to access the console and see U-Boot just fine, but it is read only. The router's RX pin does not receive input for some reason. I tried testing the voltage on my USB-Serial device's TX pin, and it works just fine (I have a second converter as well, same result.) I also tried connecting VCC to the converter in addition to TX, RX, and GND -- and the console is still read only. I checked the OpenWRT wiki page for the WR841ND (identical to WR841N, minus the detachable antennas) and while there is no information for v14.X specifically, it seems that in earlier versions, it is necessary to remove a resistor or two from the router's PCB in order for RX to receive. I found a guide online for v14.0, which advised connecting a 5V serial RX into the router's 3.3v RX pin to solve it. But it seems to me that would fry the pins...

Anyone have any idea how to fix this problematic pin?

it's not uncommon for TP-Link to cripple the RX pin, you might need to install a component (resistor ?), or short two solder pads to make it work.

1 Like

I have a soldering kit, but I am a bit scared of frying the board. I also have a breadboard and resistors on hand, including 10k Ohm ones. I was able to secure a connection by router->breadboard->converter to my PC, but I didn't connect VCC. Would it be easier for me to just add an extra resistor on the breadboard instead?

whatever works for you, but you might need to do some research, before you start adding random resistors :wink:

you do realize serial isn't needed for flashing openwrt, right ?
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=3fd97c522bb791058215e736a00b86aa8af92363

I don't plan on using the router, I just want to access the shell for the hell of it, basically. It looks like it's R18 that I need to short. Makes sense since it's right next to RX. It's an extremely tiny chip, though. No pins on the back to de-solder. Do you think soldering tweezers might do the job?

depends on how stable your hands are, never used tweezers though :frowning:

Removing R18 did the trick. The board now receives!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.