[SOLVED]TP-Link WDR4300 switch

Hi community, first of all, I don't know if this sub-forum is the right place for my question.

I'm using my TP-Link WDR4300 like a managed switch, it is a swconfig device, because of that, I can't use ethtool to set the autoneg off, and I want to confirm if this can be accomplished at other way.

root@tp-link_wdr4300:~# swconfig list
Found: switch0 - mdio.0
root@tp-link_wdr4300:~# swconfig dev mdio.0 help
switch0: mdio.0(Atheros AR8327), ports: 7 (cpu @ 0), vlans: 4096
	Attribute 1 (int): enable_vlan (Enable VLAN mode)
	Attribute 2 (none): reset_mibs (Reset all MIB counters)
	Attribute 3 (int): ar8xxx_mib_poll_interval (MIB polling interval in msecs (0 to disable))
	Attribute 4 (int): ar8xxx_mib_type (MIB type (0=basic 1=extended))
	Attribute 5 (int): enable_mirror_rx (Enable mirroring of RX packets)
	Attribute 6 (int): enable_mirror_tx (Enable mirroring of TX packets)
	Attribute 7 (int): mirror_monitor_port (Mirror monitor port)
	Attribute 8 (int): mirror_source_port (Mirror source port)
	Attribute 9 (int): arl_age_time (ARL age time (secs))
	Attribute 10 (string): arl_table (Get ARL table)
	Attribute 11 (none): flush_arl_table (Flush ARL table)
	Attribute 12 (int): igmp_snooping (Enable IGMP Snooping)
	Attribute 13 (int): igmp_v3 (Enable IGMPv3 support)
	Attribute 14 (none): apply (Activate changes in the hardware)
	Attribute 15 (none): reset (Reset the switch)
	Attribute 1 (int): vid (VLAN ID (0-4094))
	Attribute 2 (ports): ports (VLAN port mapping)
	Attribute 1 (none): reset_mib (Reset single port MIB counters)
	Attribute 2 (string): mib (Get port's MIB counters)
	Attribute 3 (int): enable_eee (Enable EEE PHY sleep mode)
	Attribute 4 (none): flush_arl_table (Flush port's ARL table entries)
	Attribute 5 (int): igmp_snooping (Enable port's IGMP Snooping)
	Attribute 6 (int): vlan_prio (Port VLAN default priority (VLAN PCP) (0-7))
	Attribute 7 (int): pvid (Primary VLAN ID)
	Attribute 8 (unknown): link (Get port link information)

If I try to set "autoneg off" at port 3, it shows that is not supported:

root@tp-link_wdr4300:~# swconfig dev switch0 port 3 set link "duplex full speed 1000 autoneg off"
Failed to set attribute: Operation not supported

I don't know if I'm using wrong the tool or that this switch doesn't support this feature

Regardless of whether it's supported, that's an invalid config. Using 1000 Mbps (and full duplex) require autonegotiation.

First, apologies by the delay to answer you, I didn't know it, thanks.

This question is solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.