Solved: TP-Link WDR4300: Bricked after installation of wrong configuration file?

Hello Forum,

My Hardware: TP-Link TL-WDR4300, Ver: 1.3.
Successfull installation of openwrt-18.06.2-ar71xx-generic-tl-wdr4300-v1-squashfs-factory.bin

Initially, I loged into Webinterface and then I accidently installed a wrong Configuration backup of OpenWrt Chaos Calmer 15.05.1.:weary:

Since then, I can not log into the router anymore (no web interface, no ssh, no ping response)

This is the current behaviour:

  1. normal power on

Power LED on
Star LED slowly flashing, after ~10 s on
both Wireless LEDs on, somtimes slowly flashing
LED of lan port on (when cable connected to PC)

LAN connection (from port 1) to my pc:

  • in Firefox->responds with LuCI - Lua Configuration Interface
    but when I click on the link I receive "no connection to server"
  • $ ping
    connect: Network is unreachable
  • $ ssh root@
    ssh: connect to host port 22: Network is unreachable
  1. So I tried a factory reset:

WPS/Reset button pressed and keep holding, then Power on WPS/Reset button released when Star LED starts slowly flashing


Power LED on
Star LED continues very fast flashing for ever and no connection possible

How can I analyze this situation more detailed and hopefully solve it?

Thank you for your support


Have you tried flashing via TFTP?

I have started with the first steps from here:

(WSP button pressed during power on -> fast flashing star LED)

$ sudo tcpdump -ni enp0s25 arp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on enp0s25, link-type EN10MB (Ethernet), capture size 262144 bytes

but no further response...

$ sudo ip addr add dev enp0s25
$ sudo tcpdump -npi enp0s25 udp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on enp0s25, link-type EN10MB (Ethernet), capture size 262144 bytes
14:20:48.742169 IP > 0 [9q] PTR (QM)? _ipps._tcp.local. PTR (QM)? _ftp._tcp.local. PTR (QM)? _webdav._tcp.local. PTR (QM)? _webdavs._tcp.local. PTR (QM)? _sftp-ssh._tcp.local. PTR (QM)? _smb._tcp.local. PTR (QM)? _afpovertcp._tcp.local. PTR (QM)? _nfs._tcp.local. PTR (QM)? _ipp._tcp.local. (141)
14:21:52.745210 IP > 0 [9q] PTR (QM)? _ipps._tcp.local. PTR (QM)? _ftp._tcp.local. PTR (QM)? _webdav._tcp.local. PTR (QM)? _webdavs._tcp.local. PTR (QM)? _sftp-ssh._tcp.local. PTR (QM)? _smb._tcp.local. PTR (QM)? _afpovertcp._tcp.local. PTR (QM)? _nfs._tcp.local. PTR (QM)? _ipp._tcp.local. (141)
14:22:20.839090 IP > NBT UDP PACKET(138)
14:22:20.839112 IP > NBT UDP PACKET(138)

As I do not understand the message above, I stopped further activities.

What should I do next?

Fast flashing means it is in failsafe mode. You should be able to log in by SSH at The web GUI is not available in failsafe mode. Failsafe is more for advanced users to fix a configuration that is only partly broken.

It would be easier to do a reset to defaults. To do that, cut the power to get out of failsafe mode, then reboot (without pressing the button) and wait until it has started up in normal mode. Wait about a minute after the light has stopped flashing and is on steady. Then press the button, hold it for 10 seconds, and release the button. Keep the power turned on. After a short time all the lights should blink off and the router reboots. It should now have standard settings as if it were just flashed.

Unexpected solution happened:

To tell the full story from the very beginning:

  1. 2 weeks ago, I purchased this router with DD-WRT installed. As I use OpenWRT on other devices, I decided to re-flash the router
  2. As mentioned here, I first flashed the factory firmware. I could access the device with web gui of TP-Link.
  3. Then I flashed OpenWRT successfully. I also could access the device with web gui of OpenWRT
  4. Then I accidentally uploaded the wrong configuration file generated by OpenWRT 15.05.1 and thinks went broke and I did lots of tries to get it going again.

Today I scanned wireless networks with my smart phone and I detected a DD-WRT(!) network. Surprisingly, I could connect to the network and I also could start the web gui with DD-WRT over with my smart phone browser.
Shortly I discovered that all my attempts to login over LAN failed, because the browser on my PC somehow "auto redirected" to the (OpenWRT) LuCI service, which failed! After clearing my broser cache I could log into DD-WRT web gui.

Main confusion caused by wrongful re-direction of my browser to (not working) LuCI
Main surprise: factory reset has revived pre-previous installation of DD-WRT.

But never mind, I just may repeat re-flashing factory firmware first, and then OpenWRT next, as I have done already :wink:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.