[Solved] TP-Link W8980/W9980 BT VDSL


I've installed LEDE on my W9980 successfully & can see the modem is syncing on the overview page, but I just can't seem to get a internet connection :frowning:

I'm with the ISP BT (British Telecom) and have the VDSL Fibre package, I've searched other topics on the forum about this router and seen that I had to change my WAN to "nas0" but that doesn't seem to work.

My config.

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'

config dsl 'dsl'
        option annex 'a'
        option tone 'av'
        option xfer_mode 'ptm'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ip6assign '60'
        option stp '1'

config interface 'wan'
        option proto 'pppoe'
        option username 'bthomehub@btinternet.com'
        option delegate '0'
        option ipv6 'auto'
        option ifname 'nas0'
        option password 'bt'

config device 'wan_dev'
        option name 'nas0'
        option macaddr 'c4:6e:1f:74:22:ba'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 2 4 5 6t'
        option vid '1'

You're using ptm, so your interface should be named "ptm0", and if you need to tag it with a VLAN ID -- which is virtually all ISPs with VDSL -- you need to tag it in the interface name. I don't have first-hand experience with BT, but a quick search suggests they need VLAN ID 101. Ergo:

config interface 'wan'
    option ifname 'ptm0.101'

config device 'wan_dev'
    option name 'ptm0'
1 Like

That worked!

Thank you so much, I really appreciate your help :smiley:

1 Like

what firmware did you use?

I used LEDE 17.01.4 - I used the default DSL driver it came with :slight_smile:



If I'm not mistaken *.sysupgrade is for upgrading an existing LEDE install.
Did you flash the abose file over the facory firmware?

I'm pretty sure that's the file I used, I followed the instructions on this page, I used the Web Interface Hack (Install OpenWrt without opening the case) method to install LEDE.


Instead of flashing openwrt, I used the LEDE sysupgrade.bin instead & it worked :slight_smile:

1 Like

OK thanks :slight_smile:

Hello @DannyBhoyyy,

I have the TD-W8980 and would like to install openwrt on it, can I follow the Web Interface Hack (https://openwrt.org/toh/tp-link/td-w9980#web_interface_hack_install_openwrt_without_opening_the_case) using the "openwrt-18.06.1-lantiq-xrx200-tplink_tdw8980-squashfs-sysupgrade.bin" firmware ?

Or if I follow the tutorial with the original firmware aka "openwrt-15.05.1-lantiq-xrx200-TDW8970-sysupgrade.image" can I upgrade to "openwrt-18.06.1-lantiq-xrx200-tplink_tdw8980-squashfs-sysupgrade.bin" firmware in web interface of openwrt ?

Thank you

(I know this is a solved thread but please don't close because this is the only few result found after a google research for this device and openwrt)

The 15.05.1 image includes some extra padding at the end of the image that the 17.01.6 and 18.06.1 images don't have, which in my experience seriously complicates completing the install because the next boot doesn't setup the overlay FS properly and the both documented approaches didn't include all the info needed to properly initialise the overlay FS that this extra padding overcomes (I have a wedged TD-W8980 on which I need to get a serial connection working in order to recover it because of this :frowning: ) .

I would recommend initially installing the 15.05.1 image then installing 18.06.1 from the web upgrade function for this reason (though I was able to able to successfully install a 17.01.6 image by adding a chunk of padding to the image before attempting the install).

You should be able to use the technique of renaming one of the radio SSIDs as documented to get access which I found is the simplest approach to installing OpenWrt on these units.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.