[SOLVED] TP-Link TL-WR1043N v5.0?

No need to use the serial port..
Tftp method to restore snapshot image then install Luci manually.
Thank you pingec !

Hello, stupid question, but I have looked at the board photos and I don't see usb port. Does v5 still have the usb port? :fearful:

No usb port present in the v5 model

Hi all, just created an account to post thanks for your work to support this thing. I am new to openWRT/Lede and bought one of these by mistake. I was going to send it back when I found this page: https://lede-project.org/toh/hwdata/tp-link/tp-link_tl-wr1043n_v5) via the hardware table. It seems support is quite new in the official build but it's in snapshot.

I was able to download an image and install version "OpenWrt SNAPSHOT r5953-d58c8f4" today with no trouble, using the OEM GUI update function. Installed Luci and QoS modules, configure it all and it's working great.

So thanks to everyone who has been hacking at this one to make it work. Seems like a nice $40 router solution.

Created an account just to give kudos for resolving support on this device. Bought it off assuming it would be nearly identical to the wr1043nd (the 'd' at the end refers to a detachable antenna). OpenWRT forums had little to no discussion about this topic.

All in all, a good router for what it costs, and thanks to the LEDE community for your efforts!
Playing around for a commercial project, will donate once in production!

I just got this router without realising this thing doesn't have USB port (N models usually only lacked detachable antennas).

So anyway, since the hw seems to be similar to 1043nd v4, did anyone tried to solder usb ports ?

Can someone please re-upload Brother_Lal's build, seeing that it's working good for two weeks makes it the best alternative until the official release.

Thank you .

why dont you use the official snapshots?

Hey, thx for the fast reply.
I'm looking for a build that's stable , i have tried in the past a snapshot(November 2017) and after figuring out how to install luci(I wasn't able to configure my pppoe connection so i had to resort to another router to supply dhcp) , I was dissapointed to find out that it would always crash under heavy load (downloading Ubuntu via deluge).

I'm looking for a image with luci so that i can configure it fast and try it .

The latest snapshot seems to be pretty decent, so try that. I'm running luci on mine without issue.

1 Like

One dumb question for all; any way to backup bandwidth statistics ? It seems that luci by default stores them to /tmp, which is undesirable when device reboots.

Any scripts or something, so it gets backed up to flash ?

Thank's for the reply, can u please test it while downloading a large file.
Because if it's stable ,I'm switching right now.

UPDATE: Tested the latest snapshot with luci , works great with my pppoe connection .

Anyone else having issues with LAN disconnects ? I'm currently running build r5986-3f7908d. It's pretty annoying to be honest.

OpenWrt SNAPSHOT r6011-805f756
No issues, running since my last post , keeps a esxi server,and my gaming pc happy, typical download speed 28-35mbps ,also a nexus 7 and a samsung s6 almost constantly connected.

I recommend you the last snapshot, works better than the original firmware.

I'm running the latest snapshop, but i still get disconnects (like i was pulling the Ethernet cable out) on my wired client.

Hello, where u downloaded the last snapshot for tl-wr1034n v5 and wath are the login and password for putty to install Luci? Or how I install luci?

Well i had something like that in the beginning , when i had it (November 2017) I restored the official firmware(latest tp-link version).

Do that and then try to flash the version I'm using.
My router has been up for 5 days with an ESXI server(realtek gigabit lan) no problem or disconect.

I will be monitoring this thread ,I;m curios about your result.

I had the last tp-link version i bought 07.02.2018.
So i figher it out wit Luci but were i download the version your using?

I hope it's allowed to share links

Here is the original archive that I currently use.
As for luci I just did the ,, opkg install luci''

Good luck!