[SOLVED] TP-LINK TD-W8970 with 22.03

I've a TP-LINK TD-W8970 which I've just upgraded to 22.03. As this changed to DSA had to do a fresh install. problem is it can't bring up ADSL although I've the same parameters as before. The relevant bits:

config atm-bridge 'atm'
	option payload 'bridged'
	option nameprefix 'dsl'
	option vci '38'
	option vpi '0'
	option encaps 'llc'

config dsl 'dsl'
	option annex 'a2p'
	option tone 'av'
	option line_mode 'adsl'
	option xfer_mode 'atm'
	option ds_snr_offset '0'
	option firmware '/lib/firmware/lantiq-vrx200-a.bin'

config interface 'wan'
	option proto 'pppoa'
	option username 'ano@plusdsl.net'
	option password 'password'
	option ipv6 'auto'
	option atmdev '0'
	option vci '38'
	option vpi '0'
	option encaps 'vc'

DSL status gives:

[Tunnel Interface] Device: pppoa-wan
RX: 0 B (0 Pkts.)
TX: 0 B (0 Pkts.)
Error: Unknown error (FATAL_ERROR)


DSL Status
Line State: Showtime with TC-Layer sync
Line Mode: G.992.5 (ADSL2+)
Line Uptime: 0h 5m 12s
Annex: A
Data Rate: 10.537 Mb/s / 888.000 Kb/s
Max. Attainable Data Rate (ATTNDR): 10.540 Mb/s / 888.000 Kb/s
Latency: 8.00 ms / 8.00 ms
Line Attenuation (LATN): 46.2 dB / 25.3 dB
Signal Attenuation (SATN): 45.2 dB / 25.8 dB
Noise Margin (SNR): 3.2 dB / 11.2 dB
Aggregate Transmit Power (ACTATP): 20.4 dB / 11.9 dB
Forward Error Correction Seconds (FECS): 8 / 0
Errored seconds (ES): 2 / 0
Severely Errored Seconds (SES): 0 / 0
Loss of Signal Seconds (LOSS): 0 / 2
Unavailable Seconds (UAS): 68 / 68
Header Error Code Errors (HEC): 132 / 27
Non Pre-emptive CRC errors (CRC_P): 0 / 0
Pre-emptive CRC errors (CRCP_P): 0 / 0
ATU-C System Vendor ID: Infineon 113.200
Power Management Mode: L0 - Synchronized

Has anyone any idea what I'm doing wrong? and any more debugging to do?

If you are connecting using PPPoA, you must delete the ATM bridge section.

See section 9.4 of guide

Bingo that solved it! Yes I noticed an ATM section had been added to what I had before - I assumed it was a new way of doing it!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.