[Solved] TP-link Archer C7 V4 build/run failures (and whole ar71xx/generic too)?

I recently tried to build master branch again with TP-link Archer C7 V4 support, but it failed on making an image (os-image was too big, I guess that it is the kernel). I was able to make bigger room for kernel by modifying tplink-safeloader.c (increase size for os-image, move and decrease size of file-system) - hopefully I did it right, the new clean build went right and finished. But the flashed image got to a boot loop (restart after few moments); pressing reset button during start-up successfully downgraded via TFTP to an older image.

Last time I tried to update from master was on 5.10.2018 with 4.9.131 kernel. Current master is using 4.14.77, this one does not build and when fixed it does not load.

It looks like not only the build of master ar71xx is widely broken (see build bot for ar71xx/generic - it is failing since 10.10.2018 for various reasons, few os-images are identical to mine), but also it does not want to boot.

Is anybody working on this or am I the only one observing strange behaviour of 4.14.77 and/or ar71xx builds?

Great, fixed in bug #1891.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.