[SOLVED] TP-Link Archer C7 V2 WAN to LAN port bridge help needed

Hello,

Currently I am using a TP-Link TL-WR740N/ND v4 with OpenWRT Chaos Calmer 15.05.1 installed.
The configuration that suits my needs has to have a LAN port bridged to the WAN since I am using an IPTV service and the Set-Top-Box needs to be exposed directly to the ISP's network.
This setup is currently configured on the aforementioned WR740N router and working, but I wanted to upgrade my router, so I bought a TP-Link Archer C7 V2 router and need to duplicate the config.
Unfortunately the Archer has some weird parts in configuring the switch and I cannot figure out how exactly I can do that.

Thanks in advance to anyone who has something to say on this topic, any help would be greatly appreciated.

Edit:

This is my current configuration on the WR740N:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.254'
	option _orig_ifname 'eth0 wlan0'
	option _orig_bridge 'true'
	option ifname 'eth0.1'

config interface 'wan'
	option _orig_ifname 'eth1'
	option _orig_bridge 'false'
	option proto 'static'
	option ipaddr 'STATIC-IP-ADDRESS-HERE'
	option netmask '255.255.255.0'
	option gateway 'GATEWAY-ADDRESS-HERE'
	option broadcast 'BROADCAST-ADDRESS-HERE'
	option dns 'DNS-SERVERS-ADDRESSES-HERE'
	option type 'bridge'
	option ifname 'eth1 eth0.22'

config switch
	option reset '1'
	option enable_vlan '1'
	option name 'switch0'

config switch_vlan
	option vlan '1'
	option vid '1'
	option ports '0t 1 3 4'
	option device 'switch0'

config switch_vlan
	option vlan '2'
	option ports '0t 2'
	option vid '22'
	option device 'switch0'

I want to somehow replicate this config on the Archer C7 and have one of the LAN ports exposed to the world :slight_smile:

On a side note, another question.
Currently I have the Archer C7 hooked up via serial cable to a dekstop machine, which is behind the WR740N router, and the WAN port of the Archer C7 is linked to a LAN port of the WR740N router.
It gets an IP address on the WAN port from the DHCP server, I am able to ping it from the gateway(WR740N) router, but no ping from the desktop machine.
Both have addresses in the 192.168.1.0/24 network - the desktop machine is 192.168.1.207 and the Archer C7 is 192.168.1.189.
From 192.168.1.254, which is the gateway ping is fine:

root@caladan:~# ping 192.168.1.189
PING 192.168.1.189 (192.168.1.189): 56 data bytes
64 bytes from 192.168.1.189: seq=0 ttl=64 time=0.627 ms
64 bytes from 192.168.1.189: seq=1 ttl=64 time=0.502 ms

From 192.168.1.207 ping to 192.168.1.189 and vice versa:

root@lede:/# ping 192.168.1.207
PING 192.168.1.207 (192.168.1.207): 56 data bytes
^C
--- 192.168.1.207 ping statistics ---
24 packets transmitted, 0 packets received, 100% packet loss
root@lede:/#

mail ~ # ping 192.168.1.189
PING 192.168.1.189 (192.168.1.189) 56(84) bytes of data.
^C
--- 192.168.1.189 ping statistics ---
18 packets transmitted, 0 received, 100% packet loss, time 17109ms

Any suggestions on this one?

EDIT: Another addition to this one.

mail ~ # arping -I eth1 192.168.1.189
ARPING 192.168.1.189 from 192.168.1.207 eth1
Unicast reply from 192.168.1.189 [18:A6:F7:7F:3E:DF]  0.648ms
Unicast reply from 192.168.1.189 [18:A6:F7:7F:3E:DF]  0.680ms
^CSent 2 probes (1 broadcast(s))
Received 2 response(s)
mail ~ # ping 192.168.1.189
PING 192.168.1.189 (192.168.1.189) 56(84) bytes of data.
^C
--- 192.168.1.189 ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1006ms

I see the MAC addresses and there is arping from the 192.168.1.207(desktop PC) to the 192.168.1.189 host(the Archer C7 WAN port).

Thanks to this answer in another topic I managed to finish the setup and now use happily my new Archer C7 V2 router with a bridged LAN port to the WAN.

Using the clarifications in the post I managed to configure the router using only the web UI :slight_smile:


Those are the current settings of the switch section and the interfaces section regarding the setup I needed.

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd48:48c1:61fb::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.24.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option type 'bridge'
	option _orig_ifname 'eth0'
	option _orig_bridge 'true'
	option ifname 'eth0 eth1.3'
	option proto 'static'
	option ipaddr 'STATIC-IP-ADDRESS-HERE'
	option netmask '255.255.255.0'
	option gateway 'GATEWAY-IP-ADDRESS-HERE'
	option broadcast 'BROADCAST-ADDRESS-HERE'
	option dns 'DNS-SERVERS-ADDRESSES-HERE'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6'
	option vid '2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0t 5'

config interface 'vlan3'
	option proto 'static'
	option ifname 'eth1.3'

Hope this helps someone else eventually.

EDIT:
Added /etc/config/network for further clarification.

i still confuse about matrix taged untaged and off
can you help me to eplain...?