[Solved] TP-Link Archer C7 v.5 - WAN not detected


#1

Router: TP-Link Archer C7 AC1750 v.5

OpenWRT: 18.06.2
openwrt-18.06.2-ar71xx-generic-archer-c7-v5-squashfs-factory.bin

ISP: RDS-RCS/DIGI (Romania), PPPoE.

When I plug the ISP ethernet cable into the WAN/Internet port, the router doesn't detect it, the WAN/Internet LED stays off, only the power and LAN1 are on. Also in the VLANS/Switch page the WAN shows "no link".

If I put another router in between, Archer router detects the cable from this router.

It's my first time using OpenWRT so I might be doing something wrong.

Thanks.


#2

You should configure your PPPoE connection. The router does not know your PPP credentials unless you set them.


#3

You need to figure out what are you outputting from your ISP modem or modem/router.

If it's just a modem then you will be outputting PPPoE, connecting the cable to OpenWrt WAN port and set your credentials there. If it's a modem/router then you could choose to set it up as bridge if it allows you (i.e. working as modem only), and set the credential on your OpenWrt router (that's pretty much like if your ISP modem is modem-only. Or you could have the routing also happening on your ISP modem/router and use your OpenWrt as a second router (that is connecting the cable to the WAN port but as DHCP client, typically).

you could also connect your ISP rouer/modem to OpenWrt LAN port, but in this case it will only function as switch/AP

image

Also have a reading through this
https://openwrt.org/docs/guide-user/network/switch_router_gateway_and_nat?s[]=gateway

So to summarize:
ISP modem <--> Open WAN port as PPPoE. Credentials entered in OpenWrt
ISP modem/router in bridge mode <--> OpenWrt WAN port as PPPoE. Credentials entered in OpenWrt
ISP modem/router (as Gateway) <--> OpenWrt WAN port as DHCP client
ISP modem/router (as Gateway) <--> OpenWrt LAN port (switch/AP only. No routing or firewall by OpenWrt)


#4

That's the first thing I did. I changed the WAN protocol to PPPoE and set user/pass.
It doesn't work. On web interface the error is "USER_REQUEST", on the syslog:

Wed Jan 30 12:29:47 2019 daemon.warn pppd[2263]: Timeout waiting for PADO packets
Wed Jan 30 12:29:47 2019 daemon.err pppd[2263]: Unable to complete PPPoE Discovery

I tried all interfaces in Physical Settings, eth0, eth0.1, eth0.2.
Do I need to set something else?

I want to replace the Asus RT-N12 router (100mbps) with this one (1000mbps).
The Internet is working fine when connected directly to the PC NIC or through the Asus router (stock firmware).

Thanks.


#5

Then your "other" router is likely sending to a DHCP client not a PPPoE . You need to make sure it's set as bridge (i.e. no routing, just sending PPPoE to OpenWrt).

When you say your PC works when connected to the first modem directly, then where do you put your username and password? And what's the WAN settings for your Asus? PPPoE or DHCP on WAN (or LAN?).


#6

If the switch port shows not connected that is a physical layer problem.

Is your modem Ethernet 100 Mb or Gb?

Using a 4 wire cable (or 8 wire cable with some wires bad) to connect two Gb ports doesn't always work.

I don't know exactly what you meant with "another router in between". It would be useful to test with an unmanaged switch in between.


#7

In case others aren’t aware, this isn’t an uncommon issue with the Archers.
If you search for “archer no wan after reboot” or similar, there are plenty of reports.

Every time, the user invariably returns to stock and the issue goes away. Returning to Openwrt they face it again.
The issue is ongoing but doesn’t seem to affect everyone.

Sometimes rebooting the whole setup and plugging it in a specific order helps, but you shouldn’t have to do that.
Root cause should be discovered.

All I’m saying is don’t dismiss this as another thread where end user couldn’t operate a toaster. :wink:


#8

ISP uses optical fiber, at my door they installed a GPON ONT. From this I have a cable with both Internet and phone lines. At the end there's a splitter where I plug the Internet and phone cables.

If I plug the Internet cable in the PC nic directly it works (pppoe on PC).
Also works if I use the Asus router, setting the pppoe user/pass in the router, dhcp on PC.

For the new router I get the error above. It doesn't detect the Internet cable.
But if I put the Asus router in between it does.

Internet -> PC : OK
Internet -> Asus Router -> PC : OK
Internet -> TP-Link Router (doesn't detect the cable)
Internet -> Asus Router -> TP-Link Router (does detect the cable from Asus)

Asus is 100mbps, TP-Link is 1000, the Internet cable is 100 but not sure.

@lantis1008
I did search, and I did try mii-too to restart the interface but it doesn't work. Also changing speed, duplex setting with ethtool.


#9

Well, if you try that then you have to have the WAN port on OpenWrt as DHCP client.


#10

When you plug the wall outlet from your ONT direct to the PC, does PC show connected at 1000 Mb (assuming the PC has a Gb port)?

Ideally you'd go out to the ONT and plug your own cable direct to its Ethernet port, but they may not allow that.

Beware of thin 4-wire Ethernet patch cables often supplied with cheap 10/100 routers. Make sure you're using a full 8 wire cable of good quality and in good condition.

What @lantis1008 is saying-- my guess is it could be something to do with how the bootloader configures the switch chip then OpenWrt re-configures it. You could try changing the VLANs around so that one of the yellow ports (numbered 2 to 5) is the WAN port instead of the blue one (number 1).

I don't think OpenWrt has a way to force a duplex or speed setting into the switch chip. swconfig is what OpenWrt uses to set up the switch chip. ethtool tends to be only applicable to ancient hardware.


#11

My theory as well, but hard to debug without an actual device to test.


#12

Because both Internet and phone lines are on the same cable (6 for Internet, 2 for phone) I assume it's only 100mbps for Internet.

I tried the Internet cable in all ports (1 WAN, 4 LAN) it's not detected.

I'll try to connect it directly to the ONT with its own cable.
EDIT:
It works connected to the ONT with a CAT 5E/1Gb cable. Why doesn't work with the 100? Do I have to change the speed/duplex settings for the WAN port?


#13

The wiring installed by your ISP is not standards compliant.

From the Wikipedia article on Gigabit Ethernet:

Since negotiation takes place on only two pairs, if two gigabit devices are connected through a cable with only two pairs, the devices will successfully choose 'gigabit' as the highest common denominator (HCD), but the link will never come up.

In other words, the devices send initial probing signals over the two-pair cable and discover that they are both gigabit capable, so they then attempt to start 1000baseT communication on all 4 pairs, which does not work. Some devices have an optional fallback to 100 Mb but most will consider the situation "faulty cabling" and simply not link.

I don't see a way to configure this in the Archer C7's swconfig. The switch is always going to use the default behavior which is try to operate at the highest speed offered by the other end. Really if your ISP is only installing two-pair cable, they should configure their ONTs to only offer 100 Mb. Of course this is a problem if they are selling service at close to or over 100 Mb.


#14

@mk24
I understand.
The cable was installed before ONT. When the ISP installed the ONT they didn't change it, ONT has ports for both Internet and phone, so they just split the wires for each port. I didn't know until now that this mean the Internet cable supports only 100mbps, my current router is 100mbps too so I had no issues.
I'll replace the cable with two, one for phone and one 1Gb for Internet.
Thanks.


closed #15

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.