[Solved] TP-link AC1750 won't use/recognize my TL-WN722N usb 2.4ghz radio

Hi there!
I'm running an AC1750 with LEDE 17.01.4, r3560-79f57e422d. The following USB drivers are installed:

root@LEDE:~# opkg list-installed | grep usb
kmod-usb-core - 4.4.92-1
kmod-usb-ledtrig-usbport - 4.4.92-1
kmod-usb2 - 4.4.92-1

I ran dmesg before connecting the TL-WN722N and then ran dmesg after connecting the TL-WN722N (and waiting 2 minutes) to look for the differences, then disconnect the TL-WN722N again and waited for 2 minutes. See the results below:

[ 1292.723817] usb 1-1: new high-speed USB device number 2 using ehci-platform
[ 1466.883137] usb 1-1: USB disconnect, device number 2

According to wikidevi the TL-WN722N is using an Atheros AR9002U chipset so i made sure i have the drivers for that installed too, as the package below:

root@LEDE:~# opkg list-installed | grep ath9k
kmod-ath9k - 4.4.92+2017-01-31-3
kmod-ath9k-common - 4.4.92+2017-01-31-3

The led light on the AC1750's usb port does light up, but the led on the TL-WN722N doesn't. Can someone tell me what im doing wrong?

The original TL-WN722N was using kmod-ath9k-htc (not kmod-ath9k), but I doubt you can still buy those. For the intermediate version you probably need rt2x00, for the more current ones some kind of Realtek driver.

It's probably easier to check it on a normal desktop system running a recent linux distribution.

//The joys of changing the underlying hardware while keeping the same product name/ number

Haha funny you said this. look at the dmesg output from plugging it into my ubuntu desktop

[75051.571748] usb 1-1: new high-speed USB device number 6 using xhci_hcd
[75051.728589] usb 1-1: New USB device found, idVendor=0cf3, idProduct=[redacted]
[75051.728593] usb 1-1: New USB device strings: Mfr=16, Product=32, SerialNumber=[redacted]
[75051.728596] usb 1-1: Product: USB2.0 WLAN
[75051.728599] usb 1-1: Manufacturer: ATHEROS
[75051.728601] usb 1-1: SerialNumber: [redacted]
[75051.729789] usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[75052.011231] usb 1-1: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
[75052.264057] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
[75052.528516] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.4
[75052.528520] ath9k_htc 1-1:1.0: FW RMW support: On
[75052.528523] ath: EEPROM regdomain: [redacted]
[75052.528524] ath: EEPROM indicates we should expect a country code
[75052.528526] ath: doing EEPROM country->regdmn map search
[75052.528527] ath: country maps to regdmn code: 0x52
[75052.528529] ath: Country alpha2 being used: CN
[75052.528530] ath: Regpair used: 0x52
[75052.540895] ieee80211 phy3: Atheros AR9271 Rev:1
[75052.742979] ath9k_htc 1-1:1.0 [redacted]: renamed from wlan0

Seems it is actually using kmod-ath9k-htc. But I'm not sure where to go from here. Does that mean i need a different driver?

Indeed (quite unexpectedly so, but) you need to install kmod-ath9k-htc (opkg update && opkg install kmod-ath9k-htc).

1 Like

Thank you so much that fixed it for me!

Just remember that after any firmware upgrade you will need to install those drivers again as frustratingly LEDE doesn't do it for you. (or at least it didn't the last time I upgraded)

I fell into that trap before when upgrading remotely and the USB dongle was the uplink, oops.

Would it be preventable if i made an firmware binary myself that includes the drivers by default?

Of course, although that would probably take longer than just running opkg. It really depends what is more convenient for yourself.