[Solved] TL-MR6400 v5 installed snapshot

I uploaded on my brand new router via tftp the recovery.bin image downloaded from here https://downloads.openwrt.org/snapshots/targets/ramips/mt76x8/openwrt-ramips-mt76x8-tplink_tl-mr6400-v5-squashfs-tftp-recovery.bin

The router boots but there is no wifi. I can connect via ethernet and I get a 192.168.1.x IP assigned by the router. The GUI is not responsive but I can connect via SSH on (root, no pass).

I tried running sysupgrade from SSH, both with the sysupgrade.bin firmware and with the recovery.bin firmware but that does not solve the situation.

I also tried reinstalling the recovery.bin firmware via tftp but the results are the same (no wifi, ethernet, DHCP and SSH working).

Does anyone have any suggestions on how to rescue this partially bricked router and install openwrt successfully?

Thank you.

snapshot images doesn't contain web ui, you have to install it manually, post flash.
wifi's disabled by default, in openwrt.

you can find the latest stable release, with web UI, at https://downloads.openwrt.org/releases/21.02.1/targets/ramips/mt76x8/


Thank you frollic, I should have realized this was the case!

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.