[Solved] TD-W9980 flashed wrong?


Sometimes ago i flashed my router with Lede/OpenWrt. Yesterday i would install openvpn-openssl, but there is not enough space for it. I'm wondering how. Using df -h says that the oberlay is only 2.8MB (available 996K). A look at the wiki-page says that there is 8MB flash available. Also the space for extroot isn't available.

I dont know how i flashed the device. But now i'm a little stumped if i flashed on a wrong way? And when, how can i fix this?


You probably need to build your own firmware to make it fit. You can check how much space the various mtd partitions use using cat /proc/mtd. Unfortunately the size is in hex.

That sounds about right. The chip is a total of 8 MB. The OpenWrt firmware itself takes about 5 MB.

If you start with a new install of the release build there should be enough space for OpenVPN though.

If you don't know what exactly is running you may consider doing a sysupgrade -n to the 18.06.1 release and start fresh.

My problem was, that i've installed some updates of installed packages. Yesterday i've learned, that the updates are installed in /overlay. After a fresh installation of 18.06.1 i've installed ddns-scripts an openvpn and now everything is working fine. Space left now 1,39MB.

Next year (sounds cool) i will expand /overlay using extroot.

Thanks and a happy new year.

@stauraum If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.