[Solved] Sysupgrade to recent snapshot hangs on boot with "Waiting for root device /dev/ubiblock0_0"

  1. Yes, it is likely that the "other" firmware version is unbootable at this time
  2. You can revert to stock on either firmware version from the OpenWrt command line, no serial required
  3. Yes, both OpenWrt and OEM firmware flash the other firmware version when "upgrading"

Reverting to OEM is accomplished by determining which version to overwrite, erasing the NAND, writing the proper firmware image, and, if needed, changing boot_part. Directions are not provided at this time as I have found that "old" directions tend to be followed blindly in the future, resulting in bricked devices.

so i can go ahead apply the patch and sysupgrade and if the need ever comes to return to stock it's possible thru command line.

some directions even if old would be better than since they can put you on the right track at least, but i do understand your point of view of taking it case by case.

thank you for your time.

@jeff linksys.sh isn't in /lib/firmware it is however in /lib/upgrade/ and in /rom/lib/upgrade/ so which one should i replace?

1 Like

My error -- /lib/upgrade/linksys.sh

The /rom/ is the ROM itself, which is "interesting" to see what was originally flashed to the device, or recover from inadvertent or unwanted changes, but there's no point writing to it. Changes there, while on the overlay (not on the flashed ROM), aren't reflected where the OS is looking for files.

1 Like

Thanks, @tmomas . I'd looked for a way to mark the topic as solved and couldn't find one. I did mark the appropriate reply.

If I understand your suggestion regarding the topic/thread, I should edit the title text as I've now done?


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.