[SOLVED] Sysupgrade fails on factory Ubiquiti Edgerouter X

Hi,

I wanted to install lede to my Ubiquiti ER-X. I have booted with a serial cable into the factory kernel over tftp stored in RAM. When I scp the sysupgrade image and try to flash it, sysupgrade fails dramatically:

root@LEDE:~# sysupgrade lede-17.01.4-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.
tar 
Cannot save config while running from ramdisk.
killall: watchdog: no process killed
Command failed: Not found
root@LEDE:~# 

Can anyone advise on how to manually flash this?

Thanks, Teun

I used the latest erx image, then latest snapshot (I recommend it for this device because of hw nat) and it worked

Are you saying the mentioned file isn't the latest?
Should I compile LEDE myself?

is the latest stable release, but is quite old
https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/
have you updated the original image to the latest one ?

I don't remember, maybe you need to use -F to force it

Ah, yes, now I see...

I'm not quite sure, I believe the original fw was 1.9.6pre3 or something...
I tried -F, to no avail...

I will try this when I'm at the device again, thanks...

I can confirm the snapshot kernel image works.

First I tried just the newer squashfs but it produced the same result, so with both the snapshot kernel and image it worked like a charm.

On the wiki it says that the er-x works in mainline, but I guess it's actually just like the er-x sfp.

Thanks!