[SOLVED]Suggested VPN solution from android to OpenWrt

Sorry, I'm not entirely clear on what you're asking. It sounds like you're running your router as an OpenVPN client.

In which case, I suspect what's happening is that your OpenVPN connection is your default route. So, if you connect to your LAN over Wireguard, the responses are going back out over the OpenVPN connection rather than through the Wireguard tunnel.

I've got a similar set-up: my router is set up as a Wireguard Client and Server. I solved this using some Policy-Based rules. My configs are posted here; I guess the pertinent bits are in /etc/config/vpr-policy-routing and option append_local_rules '! -d 192.168.0.0/16' in particular.

That's how I solved it (assuming I've understood you correctly). You may be able to do something similar. Equally, there are folk on the forum far more knowledgable than me who may provide an alternate, perhaps simpler, solution.