[SOLVED] Strongswan and kernel 4.14

Hi guys,
I have updated my DIR-860L to snapshot r6772 with 4.14.36 kernel and now I can't run anymore Strongswan.

Sat Apr 28 19:15:32 2018 authpriv.info ipsec_starter[4606]: Starting strongSwan 5.6.2 IPsec [starter]...
Sat Apr 28 19:15:32 2018 daemon.err modprobe: failed to find a module named af_key
Sat Apr 28 19:15:32 2018 authpriv.info ipsec_starter[4606]: no netkey IPsec stack detected

The installed packages are always the same, where am I wrong?
Thank you


If you compile OpenWRT from source, it uses a specific kernel and therefore you cannot use public repositories to install kernel modules.

The package in question (Strongswan) uses a kernel module named "af_key", which is contained in the package:

You will have to compile it and all of the dependencies yourself, to match your snapshot and kernel:


Hi, many thanks for your help!
When I compile from source kmod-ipsec is already selected

I tried everything and I can not find a solution.

EDIT: make clean fixed the problem.

If your question is solved, consider marking this topic as [Solved].

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.