[Solved]Ssh root@192.168.1.1 Connection refused

Please advise how to address the following issues:

  1. SSH has worked for a long time on my Linksys WRT1900AC but now I get a connection refused. No updates to OpenWRT or router OS have been made.

ssh root@192.168.1.1
ssh: connect to host 192.168.1.1 port 22: Connection refused

telnet 192.168.1.1
Trying 192.168.1.1...
telnet: Unable to connect to remote host: Connection refused

ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.253 ms

  1. By entering http://192.168.1.1 in the browser brings up the Linksys router page but not the OpenWRT admin page. Linksys router page works just fine.

Would like to get SSH working again and OpenWRT admin page to open up instead of Linksys router page.

Thank you!

I think that your device is a dual firmware unit and you had openwrt installed on one partition and the linksys firmware on the other.

Try partially rebooting your router 4 times. Pull power then plug it back in but disconnect it before it fully boots and repeat that 4 times.

4 Likes

If what @psherman suggested fails, you can reinstall OpenWrt again, but you will lose your settings.

1 Like

Alternative to the 4x power-off trick (that is explained in wiki https://openwrt.org/toh/linksys/wrt1900ac#power_switch ) :

The Linksys firmware may also offer option to "boot to alternative firmware" with should switch the boot to the other partition where you have OpenWrt.

But if that is damaged, it will then after a few unsuccesful boots switch back to the one where you have the Linksys firmware.

1 Like

Peter,
Thank you very much it worked!

SSH works again and the OpenWrt admin page comes up.

Work around details: https://openwrt.org/toh/linksys/wrt1900ac#power_switch

I am now wondering what caused Openwrt firmware to switch to Linksys firmware. Guessing when I powered it off when debugging a cable box issue. So best to shutdown using Luci. I do have the router and cable modem connected to a UPS.

If this happens again I now know what to do.

Thank you very much!! You kept me on the right path to resolve the issue.

Your support means a lot!

2 Likes

This can happen anytime the device only partially boots. So if you’ve had power glitches in general, that can cause it. Or if you were rebooting it somewhat rapidly, that may also cause the failover.

Normally, you can just unplug it, or use the LuCI shutdown method (if available on your device with advanced-reboot) or the cli poweroff command. But don’t use a reboot before you pull power because that will get you into the same situation if power is disconnected during the boot cycle.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.