[SOLVED] SSH => connection refused

upgraded to OpenWrt 19.07.0 r10860-a3ffeb413b / LuCI openwrt-19.07 branch git-20.023.41860-b349428

and now i get NETWORK ERROR: Connection refused (from WINSCP/PUTTY) and from any workstation.

used to work perfect in 18.x version.
(need this to upload certificate).

What may cause this?

Is the web interface working properly?

1 Like

Did you keep settings when you upgraded the firmware to 19.07?

Yes, LUCi is ok!
Cant be the VLAN ... that did not change either....

YES, only uploaded new firmware for this model.

What is the System-Administration page in Luci showing?


Nothing else or different

I guess the Luci has changed in 19.07. Where are the SSH settings shown in Luci now?

Can’t find them anywhere.....

Go to System-Backup/Flash Firmware, take a backup if you don't have one already and then do a Reset to defaults.
After you are able to login with SSH as well start restoring the configuration files manually and not with the Restore Backup page of Luci.

Thanks for the support!

1 Like

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like