[Solved] Speedport 504v non-invasive u-boot fails ... should I be worried?

Hi, trying to install the latest version on my old Speedport 504v.
According to this page, if I don't find a LEDE FW Install URL, I should search for old install pages and then later follow an upgrade path:

So, I found this page:

It says to first try a non-invasive load of u-boot.bin.
So, I downloaded it from this link: http://downloads.lede-project.org/snapshots/targets/lantiq/xway/u-boot-arv8539pw22_nor/

Hooked up a serial console with minicom, got into the admin menu, hit M, then made minicom send the file using xmodem protocol.
At the step where you're supposed to load it (Y ... jump to memory) and where it's supposed to start something, nothing further happens.

[DANUBE Boot]:m                                                                                                   
RAM upload destination: (default:0x80002000) : 0x                                                                 
Starting XModem download...(press Enter to abort)                                                                 
[DANUBE Boot]:y                                                                                                   
Go to Memory Address: (default:0x80002000) : 0x                                                                   
Jump to address 0x80002000 ...

Now, I'm scared to write that binary to flash. Did I DL the wrong image, or am I missing something else, obvious?


Marf ... apparently a noob issue ... I didn't realise you need to use a different u-boot image for non-invasive testing. Tried to run the nor image instead of the brn image. Looking better, now.