[solved] Some problem with wireless bridge ap and client

hi there
i install some ap in city block , and config it as bridge these ap bridging my data from main gateway to my client router which work as station and ap in same time i use image build for there router which is archer c50 v4 my problem some client access to internet but after some second they stay connected but theirs no connection i test enable dnsmasq but its same do you have any idea

this my main ap configuration

wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option htmode 'VHT80'
        option txpower '24'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'skywave-network'
        option wds '1'
        option hidden '1'
        option encryption 'psk2'
        option key 'maadar@112233'

config wifi-iface 'default_radio01'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'SKYWAVE'
        option wds '1'
        option encryption 'none'

network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdf2:d4a4:db45::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '172.0.1.2'
        option netmask '255.255.240.0'
        option gateway '172.0.1.1'
        option dns '8.8.8.8172.109.25.3'

dhcp

        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ignore '1'
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ignore '1'
config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'

and this is my client router configuration

wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10300000.wmac'
        option htmode 'HT40'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'SKYWAVE'
        option wds '1'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel 'auto'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option txpower '24'
        option disabled '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'sta'
        option ssid 'skywave-network'
        option wds '1'
        option encryption 'psk2'

network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd22:6c4b:355a::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '172.0.3.2'
        option netmask '255.255.240.0'
        option gateway '172.0.1.1'
        option dns '8.8.8.8 172.109.25.3'

dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ignore '1'
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ignore '1'
config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

other Q i install zabbix server on centos 7 machine and install zabbix agent from image build for router but its didnt work but in other place its work fine , smae configration but with different hardware .

NOTE : i use internal dns server (bind on centos machine ) with ip address 172.109.25.3 and i routing it to 172.0.0.0/20

thx

Is it a typo or you have merged the 2 IPs?

Are you sure you are allowed to use this address block? This is allocated to At&t in USA.

about dns its 2 ips but i think i get some problem with copy
its
option dns '8.8.8.8 172.109.25.3'

about ip address in my country theirs no problem with this range is it illegal ip range ?

I suppose that you are NATing these IPs. If you don't it won't work, unless you are highjacking BGP, which is in a way illegal. But even if you NAT them, you will never be able to access the real IPs. That is why there are private address spaces to use, e.g. 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16

ok , thank for this information i will change theme from 172.0.0.0/20 to 172.16.0.0

Is this problem because i use internal dns ?? If any one get this problem ?

It shouldn't be the problem there.
Is the connectivity between the ap and the client seamless, or do you have any drops?
If I understand properly the client AP has no encryption. Have you ruled out that some malicious user is connecting and causing issues the legitimate clients?

hi there
i solved this problem , i use wds for station mode and ap mode ( router config )
so i disable wds in ap and enable dnsmasq and now every things work fine .

NOTE : firewall and dhcp was disable because i have gateway ( mikrotik routerboard ccr1016 ) before my ap

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).

grafik

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.