[Solved] Some devices lose LAN connection after several hours

Been noticing this for the past week or so. Couple of TCL Roku enabled TV's will lose connection after roughly 24 hours (perhaps less) until the router is rebooted. Was using .2 but updated to .5 to see if that would correct the issue.

Only changes made recently included adding a few new devices via the DHCP and DNS page, and adding a few wireless to the MAC list for the wireless. I've verified that there are no duplicate MAC addresses or assigned IP addresses, and all the names appear to be legit (none in red).

To give an idea as to how it seems to be behaving, it's as though devices that aren't constantly connected eventually get ignored DHCP requests ignored.

Would like some ideas on what to look at/check the next time this is happening, so I can trying to determine the cause of this little annoyance.

Using a wrt1200ac Linksys router with the LEDE Reboot 17.01.5 r3919-38e704be71 build. Internet connection is fine, and other devices such as computers remain connected without issue, it's just certain devices that experience problems after a number of hours.


I believe I found the issue. While experiencing the issue, I tried a few things to try to narrow down the cause. Considering that there was no loss of internet happening (only an inability to connect to the network), I figured it had something to do with the DHCP server. Came across a setting for the maximum number of DHCP leases on that same page. Seconds after increasing that value some, the issues cleared up.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Done, thank you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.