[Solved] Snapshot suggestion (ZBT We1326)

I just purchased a ZBT1326 router from China. I loaded the snapshot, but could not load other required packages because the build is a couple of weeks old (so has an earlier kernel).

I would like to make a suggestion that on the Device page, that there is more information about the upgrade file creation date. I have been watching this build for a few weeks (another story: the Router was sent back from Australian customs twice for an unknown reason. Third time lucky!)

The only way I can see to check if the upgrade file has been updated is by downloading, then checking the size. (It has been 4,194,477 bytes for some time). This is not a critiscism of the developer, but a suggestion.
I am prepared to wait for the latest snapshot, because then I can load all the packages I require on the router. (My router will be used as an Australian NBN access router, so I require the Router packages that seem to be missing on the minimal build.)

I am a not overly competent Linux user (even tho I have used it for 18 years! Love PCLinuxOS)
& one thing I had difficulty with was knowing where to start using the snapshot. Finally read enough & worked it out, but a guide to installing snapshots including the limitations would have been appreciated. (Might even write one myself!) Ended up being relatively easy once I realised that I could connect into my existing router to get web access.. Downloaded LUCI, but had compatibility issues with other packages.

regards, Doug
ps: Thanks to all the hard working developers. I have used LEDE for quite a while, on a TP-link WDR4300.

Installation: https://openwrt.org/docs/start
Limitations: https://openwrt.org/releases/snapshot

Thanks Tmomas. I did find all the information, but for an inexperienced hacker, it took me a while to find it all, then for the light bulb to pop! I got in to UCI easily, then was a bit lost. The light bulb moment was realising that I could hook straight from the Wan port to my existing Ethernet network.
Once there it was plain sailing, except I could not load some modules I require. Hence waiting for the next snapshot release.
regards, Doug
(I am a retired Technician, so understand the importance of documentation. Often a developer does not realise the failings of the end user! No critiscism, just reality)

regards, Doug

1 Like

Did you have any luck with WE-2626 snapshot? Other users have reported success in the main thread

I successfully installed snapshot then Luci. I can log into Luci successfully now, but cannot log into ssh. I get an error 'warning host identification has changed' then cannot log into ssh.

I want to load some modules that require an up-to-date kernel (as warned about compatibility with snapshots). How can I resolve this? Is there another option than re-compiling the source? (I am not confident about undertaking that step yet. I might be a linux user, but not a competent one! I am the muddle though type...) The modules I need to load are related to Voip, & Bufferbloat. I also eventually want to use this router to monitor link speed because I want some facts to confront our NBN (National Broadband Network) about the woeful speed of the wireless NBN in Australia.

regards, Doug

If you expect a change in the keys, you can remove the "offending key" with

your-desktop $ ssh-keygen -R <IP or host name>

"Expect" would include each boot under "failsafe" mode as well as resetting to factory defaults, both of which would cause regeneration of the host key.

Thanks. Now logged in.

Is there anything I can do about the Kernel version mis-match?

regards, Doug

According to a very recent post, project-generated snapshots now have a repository of kernel modules that persist for some time. If this is a "community" build, you would have to work with the build's maintainer.

Thanks for all the help. I compiled an image, & everything seemed OK, except the wireless was not working. Turns out it is a bug in the current kernel. (I think I must have been bad in a previous life to have this much trouble!)
At least I only need to wait for the bug to be rectified, then re-compile the source.

btw, the router flies! it is so much faster than my old TP WDR4300. Cannot wait to use it!

Is your initial problem solved?
If yes, please consider marking the topic as [Solved].

Thanks. Yes, the initial problem is [SOLVED]. Still issues (with the Wireless system), but not related to initial query.
Thanks all for the help.

When I get my feet on the ground, I will document the steps for the wiki.

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.