[Solved] Small WebServer Problem on Meraki MR18 (i hope so)

Sorry but my english an my unix kowlege is small...
I tried to install OpenWrt on a Merkati MR18. I come to Step Step 5 of Flashing Methode C in https://openwrt.org/toh/meraki/mr18?s[]=meraki&s[]=mr18. The odm Commands worked well.
odm help / serial_num read/write.

My HW Setting is
local Network without Internet connection
dhcp Server
meraki receive
Windows PC running XAMPP (Port 80)
(UART Adapter works well with putty)

When i tried
odm firmware part2
i received:
wget: not an http or ftp url:

When i trie it with http://
odm firmware part2
i received:
wget: not an http or ftp url: http:

Perhaps i put the file in the wrong directorie, what is the right directorie in Windows/XAMPP? Itried a lot.
Or something else that i can do?

Additional Info. During Booting of the Merkati this Messages apperas:
[ 0.356000] Creating 5 MTD partitions on "ath79-nand":
[ 0.360000] 0x000000000000-0x000000080000 : "nandloader"
[ 0.368000] 0x000000080000-0x000000880000 : "part1"
[ 0.372000] 0x000000880000-0x000001080000 : "part2"
[ 0.380000] 0x000001080000-0x000007f80000 : "ubi"
[ 0.384000] 0x000007fe0000-0x000008000000 : "odm-caldata"

this is same as in tutorial but a little bit another adress. (352000)

Thanks a lot
Regards Peter

I don't know exactly where is the root web directory in windows, but you can verify if the file is there indeed by opening the browser and going to the address
(:80 is not needed).

Thanks for responding.
When i put http:...
i received

# Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den [Webmaster](mailto:postmaster@localhost) hierüber.

## Error 404

Apache/2.4.26 (Win32) OpenSSL/1.0.2l PHP/7.1.7

Try with
odm firmware part2

Thanks, but i do so (without the dot at the end) and i receive in this case:
wget: not an http or ftp url: http:


Looks like the file is not in the correct root directory.

The Localhost http://localhost/dashboard/ works fine.
it is the same content as

on my filesystem dasboard is directorie from XAMPP (C:\XAMPP\dasboard)
and in booth directories i put the bin file (not the downloaded gz file)

If you move the file inside the dashboard directory then you should use the following address

Thanks... I'm so stuppied.
I never checked the filename. I tried to download the file lede-ar71xx-nand-mr18-initramfs-kernel.bin
but i put "openwrt-ar71xx-nand-mr18-initramfs-kernel.bin" in the directories

I think it's the same but must check it.


One step more near to target.
When i put it to the Browser it worked (Open downlaodmessage) booth adresses with an without http: in front

Bit when i put this with to Meraki console
odm firmware part2 192.168.... (really double checked the same)

i received the old error messages
wget: not an http or ftp url: http:
wget: not an http or ftp url:
(Last without http)

Any Ideas? Perhaps no It's a timing problem.

Can you try from another device in the LAN that you can access the file? Maybe windows firewall is blocking the webserver, or the webserver has some access list.

Yes i could.
Testing with Apple Tablet and safari. The response on the url 192.... kernel.bin is the offer to open it in moddle or do some other transactions.

Browsers automatically add http:// if you forget to put it in the address box. wget requires you to explicitly put http:// on the command line before the rest of the URL, or it will not work.

not using http:// in the URL is part of the hack. see: https://snt.sh/2017/06/pwning-the-meraki-mr18-again/, chapter "why this works".

... Thank's to all who answered. Now it works's fine. I could be the start of a great love ;-))

I think the problem was that (on windows) there are "" arround the adress are needet.

@OpaPeter If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Sorry i could not find this special pencil. In Top i could change categorie and belo, what i have already written. In my personal overview of "my" topics i could also not find such an function.
I think I'm little bit blnd or it's realy god hidden...

It is hidden behind the 3 dots.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.