SOLVED - Setup VLAN ID 7 for ISP with TP Link Archer VR200v (WAN not shown in Network -> Switch configuration table

I need to use VLAN ID 7 for my ISP to connect. I tried several configurations and hours of time are wasted.

In the Network -> Switch configuration table there is no WAN port column shown, so I am unable to tag the WAN port with VLAN ID 7, which I think is necessary.

(See ... CAUTION: The interface seems to be < OpenWrt 21.xx.x and looks slightly different to my interface, but my point is the missing WAN column.)

Further information:
Model TP-LINK Archer VR200v
Architecture xRX200 rev 1.2
Firmware Version OpenWrt 21.02.0 r16279-5cc0535800
Kernel version 5.4.143

Are you using the integrated xDSL modem or an external modem? In the former case, change all instances of dsl0 to dsl0.7 in /etc/config/network and read the great bthub5 guide from (while the devices aren't the same, many hints apply alike).

1 Like

Changing the twofold occurrences of dsl0 to dsl0.7 in /etc/config/network did the trick. Thanks so much!

Steps to reproduce.

  1. Login via webinterface (luci)
  2. Go to System->Backup/Flash firmware->Perform reset
  3. Wait for reset, then login again via luci
  4. Go to System->Administration
  5. Set up password for login
  6. Go to Network->Interfaces->Edit WAN
  7. Setup all necessary stuff for your ISP (in my case username, password and mtu (in advanced tab)
  8. Save and apply
  9. (If necessary go to Network->Interfaces->DSL and change accordingly to your ISP)
  10. Go to Network->Switch and add VLAN
  11. Replace "2" with "7" in port number
  12. Save and apply
  13. Login via ssh
  14. Change the (in my case) twofold occurrences of dsl0 to dsl0.7 in /etc/config/network
  15. (In my case reboot the router via web interface until DSL line works [see status page])

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.