[Solved] Setting up wiregiard client. Problem connecting to server

Hi, I have
OpenWrt 22.03.5 r20134-5f15225c1e
I also have WG profile to my own WG server at home.
I can not seem to make it connect on my OWRT.
I fillowed all guides, but I notice I got Public Key under general settings in the WG interface creation.
All examples dont have that, public key is only required in peer tab.

image

Any idea how to set the client up?

Also I have a openvpn connection, but this is turned off at the time of settign WG interface.

You only need a private key.

The public key is calculated from the private key.

The Peer section has the public key of the Peer

2 Likes

Hi
I got it working.

How can I make it work in conjunction with openVPN.
I got OVPN with kill switch (in firewall). But when I disconnect WG, I got no internet on my devices.

Research Policy Based Routing (PBR) e.g.:

If you have questions about PBR, open a new thread.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

I think this PBR is above my grade.
I dont need to have the OVPN and WG on at the same time.
I just need to be able to connect one or the other as I want.
Is there an easy way for that?

Disable one or the other, but if you have made a killswitch by disconnecting LAN from the WAN you also have to revert that.

I need to have a kill switch for both VPNs?
Can there be only one kill switch with LAN zone to OVPN/WG zone?
Like this (dont work)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.