[Solved] Setting-up an HE IPv6 tunnel with /64 delegation in OpenWrt

Dear all,

I followed HE.net tutorial to set-up an HE /64 tunnel in OpenWRT:

uci set network.henet=interface
uci set network.henet.proto=6in4
uci set network.henet.peeraddr=mypeer
uci set network.henet.ip6addr='P::2/64'
uci set network.henet.ip6prefix='IP::/64'
uci set network.henet.tunnelid=mytunnelid
uci set network.henet.username=myuser
uci set network.henet.password='mypassword'
uci commit network

uci set firewall.@zone[1].network='wan henet'
uci commit firewall

/etc/init.d/network restart
/etc/init.d/firewall reload

I also installed:
luci-proto-hnet

It works fine. However in Luci, when clicking on henet interface, luci tells "protocol unsupported". How to set up an HE tunnel in LuCi?

Kind regards,

I believe you need luci-proto-ipv6

1 Like

Thanks. I installed it. LuCi still answers:

Unsupported protocol type.
Install protocol extensions...

Also clicking on Add interface does not propose HEnet.

Think I need to enable a n incoming firewall port on WAN.

All config is explained here:
https://openwrt.org/docs/guide-user/network/ipv6_ipv4_transitioning

The protocol is called 6in4.
You can try to logout/login, restart the uhttpd, reload the router and check again.

From:
https://openwrt.org/docs/guide-user/network/ipv6_ipv4_transitioning

I followed the WIFI tutorial and I am still stuck, here is my configuration;

/etc/config/network

config interface 'wan6'
	option proto '6in4'
	option peeraddr ''
	option ip6addr 'xxx::2/64'
	option ip6prefix 'xxx::/64'
	option tunnelid ''
	option username ''
        option updatekey ''

/etc/config/firewall

config rule
        option name     'Allow-protocol-41'
        option src      'wan'
        option proto    '41'
        option target   'ACCEPT'

config rule
    option name         'Allow-protocol-59'
    option src          'wan'
    option proto        '59'
    option target       'ACCEPT'
    option extra        '-m length --length 40'

Does it appear now on the Luci page?
Does the henet configuration page have your IP endpoint address?

Still no luck with Luci. I also switched back to the exact configuration provided by the WIKI:

# /etc/config/network
config interface 'wan6'
        option proto     '6in4'
        option tunlink   'wan'
        option mtu       '1424'                      # the IPv6 tunnel MTU (optional)
        option peeraddr  '216.66.80.30'              # the IPv4 tunnel endpoint at the tunnel provider
        option ip6addr   '2001:0DB8:1f0a:1359::2/64' # the IPv6 tunnel address
        option ip6prefix '2001:DB8:1234::/48'        # Your routed prefix (required)
        # configuration options below are only valid for HE.net tunnels, ignore them for other tunnel providers.
        option tunnelid  '12345'                     # HE.net tunnel id
        option username  'username'                  # HE.net username used to login into tunnelbroker, not the User ID shown after login in.
        option password  'password'                  # HE.net password if there is no updatekey for tunnel
        option updatekey 'updatekey'                 # HE.net updatekey instead of password, default for new tunnels

Still no luck.

I cannot see any IPv6 in ifconfig.

Maybe I should follow this ...
https://openwrt.org/docs/guide-user/network/ipv6/ipv6tunnel-luci

What are the available protocols in the drop down list?

Solved. I missed the 6in4 protocol which is not a dependency of luci-proto-henet for strange reasons.

opkg install 6in4 
Solved the issue.

Many thanks.

There isn't a luci-proto-henet. Do you mean lucl-proto-hnet? That's the luci support for the Homenet Control Protocol which has no reason to have 6in4 as a depenency.

1 Like

Thanks. Removing it.

I have quite good bandwidth behind fiber:

iperf3 -6 -c bouygues.iperf.fr
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  7.62 MBytes  63.9 Mbits/sec    0    388 KBytes       
[  5]   1.00-2.00   sec  46.0 MBytes   386 Mbits/sec   88    626 KBytes       
[  5]   2.00-3.00   sec  45.0 MBytes   377 Mbits/sec    0    677 KBytes       
[  5]   3.00-4.00   sec  36.2 MBytes   304 Mbits/sec   88    508 KBytes       
[  5]   4.00-5.00   sec  36.2 MBytes   304 Mbits/sec    0    552 KBytes       
[  5]   5.00-6.00   sec  23.8 MBytes   199 Mbits/sec   21    420 KBytes       
[  5]   6.00-7.00   sec  28.8 MBytes   241 Mbits/sec    0    465 KBytes       
[  5]   7.00-8.00   sec  31.2 MBytes   262 Mbits/sec    0    510 KBytes       
[  5]   8.00-9.00   sec  23.8 MBytes   199 Mbits/sec    0    543 KBytes       
[  5]   9.00-10.00  sec  26.2 MBytes   220 Mbits/sec   21    403 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   305 MBytes   256 Mbits/sec  218             sender
[  5]   0.00-10.02  sec   302 MBytes   253 Mbits/sec                  receiver

Latency is good:

ping6 bouygues.iperf.fr
PING bouygues.iperf.fr(2001:860:deff:1000::2 (2001:860:deff:1000::2)) 56 data bytes
64 bytes from 2001:860:deff:1000::2 (2001:860:deff:1000::2): icmp_seq=1 ttl=58 time=25.3 ms
64 bytes from 2001:860:deff:1000::2 (2001:860:deff:1000::2): icmp_seq=2 ttl=58 time=15.7 ms
64 bytes from 2001:860:deff:1000::2 (2001:860:deff:1000::2): icmp_seq=3 ttl=58 time=15.1 ms
64 bytes from 2001:860:deff:1000::2 (2001:860:deff:1000::2): icmp_seq=4 ttl=58 time=17.2 ms
64 bytes from 2001:860:deff:1000::2 (2001:860:deff:1000::2): icmp_seq=5 ttl=58 time=29.5 ms

The tunnel speed can probably go at a higher speed.
I am quite delighted with OpenWRT, thanks.

Closing and creating a new thread.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.