[SOLVED] Setting ethernet duplex under bridge with DSA

Hi,

Printer is on lan4, which lies under the bridge br-lan. Now unfortunately under auto negotiation it is configured at 100/FD when the printer is only 100/SD. But the problem is how do I set the duplex by hand?

When I use ethtool I get:

ethtool lan4@eth0
Settings for lan4@eth0:
Cannot get device settings: No such device
Cannot get wake-on-lan settings: No such device
Cannot get message level: No such device
Cannot get link status: No such device
No data available

Do I need to take lan4 out from the bridge, before access under ethtool? Is there any openwrt/DSA way of setting this? e.g. I can see the settings under the web internet under network/devices - but don't seem to be able to set duplex there - just see that its 100/FD.

Any ideas?

Try using just lan4 here (without @eth0).

Bingo - that worked. I guess lan4 got renamed when it was included in the bridge?

DSA doesn't rename interfaces AFAIK. I'm not sure why you are calling ethtool with lan4@eth0, is that a swconfig remnant?

No, you likely got that name from ip link. It will use the name@name notation to display the master interface of a given interface. In the case of DSA on your board, eth0 is the DSA master interface and lan1 .. lanX are subordinate ones.

This notation is used for different kinds of interface types, e.g. for VLAN ones where you'd see something like eth0.10@eth0.

So in short, no nothing got renamed and the @eth0 part is an ip link display artifact.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.