[Solved] Set custom MAC on ath79 target

Hi,

I've been migrating from ar71xx to ath79 on my devices.

The Problem is that i can't set a custom mac any more, neither via Luci nor via SSH.

The setting "Option macaddr 'xx' " is there in /etc/config/interfaces, but it just gets ignored.

Can somebody help me?
Thanks a lot, basti

Add according to your lan/wan iface name:

config device 'lan_eth0_dev'
        option name 'eth0'
        option macaddr ':E0:B0:AA'
config device 'wan_eth1_dev'
        option name 'eth1'
        option macaddr ':48:FC:B4'
1 Like

Thank you for the answer. My devices are wifi Clients, though, and i can't get it to work.

I tried your commands, also changing device to wlan0 and radio0. I don't See any Changes, though. Probably i'm using the wrong interface Name?

That's the network where i want to change the mac address:

config interface 'wwan'
        option name 'wlan0'
        option proto 'dhcp'

I'm at a loss what's the right interface Name. Can you help me out?

Thanks :slightly_smiling_face:

you need change that under the wifi config

config wifi-iface
	option network 'wwan'
option macaddr 'xx:xx:xx:xx:xx'

Your configuration looks quite wrong to me. You wouldn't configure dhcp in /etc/config/wireless where you would change the MAC for WLAN devices like @bricco1981 has written. I think you are mixing up things a bit.

Post the output of:

uci show wireless && uci show network && uci show dhcp

Don't forget to redact any passwords or other sensible informations.

Yes, thanks, that worked :slight_smile:

What's confusing: under ar71xx that gets done in the network file, or in network/interfaces via luci. That Option still exists, but it has no effect. I would consider that a bug...

That was /etc/config/network, you're right. That's where i did it under the old target.

I wrote that post before@bricco1981 answered :wink:

Anyway, my Problem is solved, maybe i'll file a bug report because the old, not working Option is still there...

Pls mark the topic as solved.

Done. Can't edit the topic, though.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.