[Solved]Samba & WIndows 10

I have installed openwrt v18.6.2 on a PlusNet Hub One successfully. I then installed the app to talk to USB devies and Samba36. I was able to access (read/write/create folders) the share USB from three Windows 10 PCs for several days, then one PC refused the connection stating it did not accept SMB1. To my knowledge the Windows PC in question did not receive any updates. I assume that the Samba 36 package implements SMB3.
I have added the following lines to /etc/samba/smb.conf.template:

	client max protocol = SMB3
	client min protocol = SMB2
	server max protocol = SMB3
	server min protocol = SMB2

The PCs which still works report:
Edition: Windows 10 Home; Version: 1803; Build: 17134.590
Edition: Windows 10 Pro; Version 1809; Build: 17763.316

The PC which worked until Monday this week but now fails reports;
Edition: Windows 10 Pro; Version: 1803; OS Build: 1734.590

I understand that Microsoft stopped including SMB1 support from Edition 1709 however all PCs report in their Samba server config:
EnableSMB1Protocol : True
EnableSMB2Protocol : True

The Samba client configuration files on all 3 PC are identical.

Can anyone explain:

  1. why one PC stopped workign from one day to the next?
  2. how to get the failed PC back working?

Thanks for any help.

I am not sure the server will use this file as configuration. smb.conf maybe, but smb.conf.template highly unlikely.

This assumption is incorrect, samba 3.6 is the first version to include support for the SMB2 protocol, for SMB3 you need at least samba 4.1.


When Samba is restarted with /etc/init.d/samba restart the /etc/samba/smb.conf file is recreated from the uci configuration file and /etc/samba/smb.conf.template so the values I put it the template file do end up in the smb.conf file. I have checked and they are there.

You are right! Disregard my previous post.

Try to apply the default value max protocol = SMB2 and purge the others.
In any case, if 2 windows clients are connecting without issues while the third can't, it would mean that the problem lies in the third client.
Also try to reboot the openwrt, not just restart the service.

1 Like


As tendy said the issue was in the PC which wouldn't connect. On the PC which would not connect the freature SMB 1.0 Client was not installed, it was installed on the other PCs. It is interesting that Windows reported 'EnableSMB1Protocol: True' on all three PCs although it was only installed on two of them.

I have Samba on Openwrt set for

client max protocol = SMB3
	client min protocol = SMB2

but its obviously negotiating SMB 1 with Windows.

Thanks for your help.

SMB1 support in Windows 10 is an optional component that's not enabled by default, though it can be turned on form Control Panel > Programs > Turn Windows features on or off

(1809 Pro)

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.