[SOLVED] Router won't let me apply lede-17.01.6-ar71xx-generic-tl-wr741nd-v2-squashfs-sysupgrade.bin


I have downloaded lede-17.01.6-ar71xx-generic-tl-wr741nd-v2-squashfs-sysupgrade.bin (from https://downloads.openwrt.org/releases/17.01.6/targets/ar71xx/generic/) for my **TP-LINK TL-WR741ND rev 2 ** (as per /proc/cpuinfo), I'm currently riunning the ancient BARRIER BREAKER (Bleeding Edge, r36713) and nothing happens when I select the image and hit Flash Image... under System -> Backup / Flash Firmware (in Luci). I tried it from the shell too but got:

sysupgrade -v /tmp/lede-17.01.6-ar71xx-generic-tl-wr741nd-v2-squashfs-sysupgrade.bin 
Invalid image, hardware ID mismatch, hw:07400001 image:07410001.
Image check 'platform_check_image' failed.

I understand that this means I should use the TL_WR740ND fw instead even though I get:

cat /proc/cpuinfo 
system type             : Atheros AR7240 rev 2
machine                 : TP-LINK TL-WR741ND
processor               : 0
cpu model               : MIPS 24Kc V7.4
BogoMIPS                : 232.24
wait instruction        : yes
microsecond timers      : yes
tlb_entries             : 16
extra interrupt vector  : yes
hardware watchpoint     : yes, count: 4, address/irw mask: [0x0ffc, 0x0ffc, 0x0ffb, 0x0ffb]
ASEs implemented        : mips16
shadow register sets    : 1
kscratch registers      : 0
core                    : 0
VCED exceptions         : not available
VCEI exceptions         : not available

plus https://downloads.openwrt.org/releases/17.01.6/targets/ar71xx/generic/ doesn't have a v2 fw for the 740...

t looks appears as if lede-17.01.6-ar71xx-generic-tl-wr740n-v1-squashfs-sysupgrade.bin was the correct version, it let me upgrade & reboot the router & it came back up and running just fine with the previous config in place, too! :slight_smile:

1 Like

The Table of hardware is your friend, no need to manually wade through the download directories searching for the correct image for your device. :slight_smile:

BTW: If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

1 Like