[solved] Router configuration in Wi-Fi bridge mode: Firewall, DNS, DHCP

Hello,

I have configured my router in mode Wi-Fi bridge with relayd according to this setup guide.

In my network there's a Wi-Fi AP, to which the router is connected in client mode, and another router (running VyOS) connected to the ISP. On this VyOS router I have configured DNS, DHCP and Firewall.

Question:
Assuming there should be only one service for DNS, DHCP and Firewall in the network, would it make sense to stop all these services dnsmasq, odhcpd, firewall on OpenWrt router?
And if yes, will the Wi-Fi client still connect to the AP using DHCP?

THX

It is not necessary to have only one of those services running, but if you don't know how to configure them properly then better leave only one running. However the guide is turning off the dhcp server and assigns all interfaces involved in relayd to the lan zone.

The Wifi clients take settings from the VyOS router anyway.

1 Like

Let me precise my last question:
If I stop service odhcpd, will the OpenWrt router still connect to the AP using DHCP for IP address lease?
Or must I create a static IP for this interface if odhcpd is off?

odhcpd is used for DHCP6 server.
The dhcp client is udhcpc.

1 Like

There's no such service udhcpc.

root@net3-tplwr841:~# ls -l /etc/init.d/
-rwxr-xr-x    1 root     root          1122 May 16 20:32 boot
-rwxr-xr-x    1 root     root           821 May 16 20:32 cron
-rwxr-xr-x    1 root     root         30148 May 16 20:32 dnsmasq
-rwxr-xr-x    1 root     root           255 May 16 20:32 done
-rwxr-xr-x    1 root     root          5948 May 16 20:32 dropbear
-rwxr-xr-x    1 root     root           997 May 16 20:32 firewall
-rwxr-xr-x    1 root     root          1013 May 16 20:32 gpio_switch
-rwxr-xr-x    1 root     root          3504 May 16 20:32 led
-rwxr-xr-x    1 root     root          2383 May 16 20:32 log
-rwxr-xr-x    1 root     root          2794 May 16 20:32 network
-rwxr-xr-x    1 root     root           292 May 16 20:32 odhcpd
-rwxr-xr-x    1 root     root          2313 May 16 20:32 relayd
-rwxr-xr-x    1 root     root           436 May 16 20:32 rpcd
-rwxr-xr-x    1 root     root          1212 May 16 20:32 sysctl
-rwxr-xr-x    1 root     root           662 May 16 20:32 sysfixtime
-rwxr-xr-x    1 root     root          2163 May 16 20:32 sysntpd
-rwxr-xr-x    1 root     root           978 May 16 20:32 system
-rwxr-xr-x    1 root     root          1339 May 16 20:32 ucitrack
-rwxr-xr-x    1 root     root          5414 May 16 20:32 uhttpd
-rwxr-xr-x    1 root     root           125 May 16 20:32 umount
-rwxr-xr-x    1 root     root           239 May 16 20:32 urandom_seed
-rwxr-xr-x    1 root     root           220 May 16 20:32 urngd

ps wwww | grep dhcp

This is the output:

root@net3-tplwr841:~# ps wwww | grep dhcp
 1588 root      1212 S    udhcpc -p /var/run/udhcpc-wlan0.pid -s /lib/netifd/dhcp.script -f -t 0 -i wlan0 -x hostname:net3-tplwr841 -C -O 121
 2006 root      1212 S    grep dhcp

The output is still the same after stopping service odhcpd. Therefore I will disable this service.

The dhcp client udhcpc is not a service. It runs when the interface configured as dhcp client comes up.
As I mentioned before, the odhcpd is the dhcp6 server. You may want to disable the ip6assignment as well as the RAs and DHCP6 on the lan interface, rather than just disabling the service.

Thanks for your support.
I think this issue is solved; I'll mark it accordingly.

Unfortunately there's a more severe issue I'm facing now, but I have opened a seperate thread for it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.