[SOLVED] Root password not able to reset

Using a TPlink WDR3600 here, where I can login as root in failsafe mode, but not login when in normal mode. In SSH my password is not accepted and Luci shows: No root node was registered...

What did I do:

  • reflash firmware, with deleting old settings
    • booted to failsafe mode
    • mount_root
    • sysupgrade -n -v /tmp/flash.bin

and in a next failsafe boot cycle
*fill in twice my password. Feedback is that passwd is changed.

Any ideas?

Maybe it has to do with my last action before it went wrong: changing the VLAN settings. However, the procedure above should reset everything to default, right?

Have you tried using the reset button?

Yes I tried now the reset button: either holding it during power on, or pressing it for >10secs during normal operation does not defer it from normal operation. You would almost belief the reset button is defect. However it does bring the WDR3600 in failsafe mode when triggering at the right moment

Finally cracked it: I used this guide to flash the original TP-link firmware via TFTP.
Note, I renamed the firmware file to wdr3600v1_tp_recovery.bin.
Via the web server of the TPlink firmware I updated to lede-17.01.4-ar71xx-generic-tl-wdr3600-v1-squashfs-factory.bin
Now I can login via LuCi and SSH again.

1 Like

For posterity: Did you initially flash the ...-sysupgrade.bin file?

yes but with sysupgrade -n option included

Thank you, so this is still a thing. Some devices seem not to be properly "partitioned" when initially flashing the -sysupgrade image instead of the -factory one, with the consequences you observed. I remember this being a common problem in the past.

1 Like

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.