[Solved] Revert from openwrt to TP-link tl-wa901nd-v2

Good day! I installed this: lede-17.01.4-ar71xx-generic-tl-wa901nd-v2-squashfs-factory.bin

But my wireless signal dissapeared and now I want to revert to the original tp link software. I tried to find how, but I could not.

My router is a wireless access point with no ether et ports to connect to the PC, only 1 port for a connection to another router. Any ideas on how to revert?

I have this device: tl-wa901nd v2.

Did you manually enable wireless via LuCI or SSH after flashing, as Wireless is disabled by default for security.

1 Like

After flashing, it is configued to work like a regular router but only one port. Connect it directly to your PC with no other network and obtain an IP address automatically. Then you can log in to and configure it.

If you want to go back to stock, find or prepare a "stripped" version of the TP-LINK firmware then flash it with the upgrade firmware page.

1 Like

Sorry for the long time it took me to reply. I am at work every day and barely have time for anything.

I did not configure anything as I can not connect through wireless.

I will try connecting through the 1 port on the back, but normally that port is for receiving the signal, will it be Allright?

I've never used the device you have, but you should be able to connect to it via ethernet. If not, I would recommend filing a bug report stating the ethernet port needs to be apart of LAN as default, as there's no way for wireless to be set as enabled, unless you compile your own image, as there's no way to secure the WiFi network (hence why it's disabled by default).

Will there be a LUCI (GUI) with the file I flashed? Or will I need to set it in some other way.

I did it with a cable and PC and now it works and it's better than the tp link software.

If your problem is solved, please consider marking this topic as [Solved].

I searched, but I can not find how to do that?

Just click the pencil symbol behind the topic.
I did this now for you.

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.