[SOLVED]Restoring TD-W8960N v1

After successfully flashing device with LEDE I made errors with UCI commands while following a tutorial to configure the device and I no longer can access the device via network.

Is it possible to restore LEDE factory defaults ?

SSH in to the router and run the following...



The router is no longer accessible via ssh, It seems all the Ethernet ports are down

Try getting into failsafe mode...


Do you have a wifi switch key behind the router? Try turning off and on wifi pressing it and see if your wlan starts.

No wifi key.
Looks like I need to do some soldering and attach UART

Try this tutorial, which works for several TP-Link routers -

Rename the stock firmware file to w8960v1_tp_recovery.bin

Thanks I used the tftpd64 to flash the router initially, great tool.
I will change my PC IP to and try again.

Some people have been inquiring about flashing TD-W8960N
Initial Flash was done with PC IP set to (anything will do)
from https://archive.openwrt.org/snapshots/trunk/brcm63xx/generic/
renamed to openwrt-cfe.bin , just easier to type



 > tftp
BusyBox v1.00 (2011.11.30-07:41+0000) multi-call binary

Usage: tftp [-p|-g] [-t i|c] [-f filename] tftp_server_ip

Update firmware image and configuration data from OR backup configuration
data to a tftp server.

-g -t i -f filename server_ip   Get (flash) broadcom or whole image to modem
-g -t c -f filename server_ip   Get (flash) config file to modem
-p -f filename server_ip        Put (backup) config file to tftpd server

  > tftp -g -t i -f openwrt-cfe.bin
Allocating 4194324 bytes for flash image.
Memory allocated
Got image via tftp, total image size: 3407876
Flashing root file system and kernel...

Looks like it is bricked, can't enter failsafe/recovery.

I have another router TD-W8960Nv3 I will continue testing with that for now.

I think you would need to configure two VLANs...one for the new WAN, and one for the new LAN ports.

  • This topic is marked [SOLVED] -> Where is the solution?
  • The topic is Restoring TD-W8960N v1 with the initial question Is it possible to restore LEDE factory defaults ?.
    The new question

does not belong to this topic. -> Please open a new topic for this new question.