[Solved] Remove packages while overlayfs is mounted read-only

I'm getting this error

Your JFFS2-partition seems full and overlayfs is mounted read-only.
Please try to remove files from /overlay/upper/... and reboot!

and here is output of df:

root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.3M      2.3M         0 100% /rom
tmpfs                    28.9M      1.2M     27.7M   4% /tmp
/dev/mtdblock4            3.9M      3.8M     96.0K  98% /overlay
overlayfs:/overlay        3.9M      3.8M     96.0K  98% /
tmpfs                   512.0K         0    512.0K   0% /dev

The thing is I can't find any files I can delete there, so I want to remove some packages but it doesn't work

root@OpenWrt:~# opkg remove inadyn
Removing package inadyn from root...
root@OpenWrt:~# opkg list | grep inadyn
inadyn - 2.7-1 - Inadyn is a small and simple Dynamic DNS, DDNS, client with HTTPS support
inadyn - 2.5-1
root@OpenWrt:~#

What do i do here? I'm kinda stuck in a loop here, The flash is full so root is mounted as readonly, but i cant remove packages which I'm guessing is because root is mounted as read only...

I wanted to just reinstall/reset openwrt, but the installation was just such a huge pain that I really don't want to do it again.

This is on a TP-Link TL-MR3020 V3, so the flash is very small, i also haven't upgraded the firmware since I installed openwrt so its still running OpenWrt SNAPSHOT r11126-cb289777ca and I don't think i can upgrade the fw if the flash is full and root is ro

jffs2 doesn't handle disk full events that gracefully, it' usually better to reformat the jffs2 filesystem in this case, instead of trying to fix it by removing files.

I'd suggest to backup what you may need and then start over again, e.g. by using firstboot from within the failsafe environment (not the running system, as the later would try to delete files, while the failsafe environment would format the filesystem). Alternatively you can sysupgrade -n <firmware.bin> a newer (or the same) firmware version again.

3 Likes

Thanks, I was able to firstboot from the failsafe and sysupgrade to the latest firmware version, i also managed to get extroot working so now i have 32gb flash storage, I tried a 2gb usb drive but i got too many problems so i tried with this 32gb usb drive and it works.
It took me like a couple hours to get it all working, but it works now...

also, would a usb hub work with openwrt and this tl-mr3020? would be cool if i can plug something else to this

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.