[Solved] Redmi AX6000 can't log to router on 192.168.1.1

Yesterday I installed OpenWrt on my Redmi AX6000. I can not connect to 192.168.1.1 using wifi connection. It is only possible if i connect my laptop using lan cable. How to fix it?

use the wired connection to enable wifi ?

https://openwrt.org/docs/guide-quick-start/basic_wifi

Yes I enabled wifi using webui and connected succesfully. I am connected to this network. It works, but the speeds are random.

  • they usually are
  • define "random"
  • what are you testing, and how ?
  • have you set a country for your wifi ?

I have 1GB and speeds are sometimes 50 megabit, sometimes 700 megabit, sometimes 450.

I test using speedtest.net

I set my my country in settings.

But why I can't connect to 192.168.1.1 when on wifi?

welcome to internet.
test using a wired connection.

because you probably misconfigured something, or aren't connected to the correct wifi.

Wifi is correct. Can I reset OpenWrt to default settings somehow? Will it help?

there's a "Perform reset" option in System -> Backup / Restore Firmware.

probably, but we can only guess.

the default settings are correct, you "only" need to set the wifi name, password, encryption and country.

Ok, probelm connecting to 192.168.1.1 sovled. Is there really nothing to do to have more stabe internet speeds? I am like only 5 meters from router.

Call your ISP and complain...

By default, the config for a new install to a router disables wifi as a security measure. I can't remember if wifi has a default SSID set. 'OpenWRT' without encryption, which isn't secure if left unconfigured.

You seem to have received snark and abuse for your concerns about the wifi speeds - as an openwrt member, i can only apologize, and hope others will stop by and offer useful suggestions.

The wifi basics i would check (for each interface listed in Network -> wireless overview):

  • correct country code, (under 'Advanced settings')
  • channel set to 'auto', bandwidth set as you want it,
  • mode set to the fastest for the given frequency.

Those are the first things to check, after that, degubbing wifi speed changes becomes more of a challenge. Suspicious messages in the log (Status->System Log) ?

Interference from other devices, nearby networks? Others pirating your connection if you haven't set wireless encryption method and password?

Good luck, hopefully you can search this category for wireless speed debugging. There will be many threads on this!

Thank you. It was a very helpful suggestion. I had it set on channel 1 and 36, not auto. We'll see how this works now.

Fyi, specifying a specific channel could force the radio being disabled if that one channel is not available.

At a minimum it may force your traffic onto a channel already crowded by some of your neighbors.

Even though I set it to "auto", it still uses channels 1 (2.4GHz) and 36 (5GHz). I assume it takes a while to set to the optimal channel?

I feel that there is a lot of guessing, but it would be best to see the config to be able to determine what is actually happening on the device.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
ifstatus wan | grep address

For the last one (ifstatus wan), please only post the first two octets (in bold: aaa.bbb.ccc.ddd)

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.167",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 4",
        "model": "Xiaomi Redmi Router AX6000 (stock layout)",
        "board_name": "xiaomi,redmi-router-ax6000-stock",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05-SNAPSHOT",
                "revision": "r24133-33b45c0a0e",
                "target": "mediatek/filogic",
                "description": "OpenWrt 23.05-SNAPSHOT r24133-33b45c0a0e"
        }
}

=========================================================================================

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9d:be3b:8a3c::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'macmacmacmacmacmac'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
		
=========================================================================================

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi'
        option channel '1'
        option band '2g'
        option htmode 'HE20'
        option country 'PL'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'passpasspasspasspasspass'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/soc/18000000.wifi+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option country 'PL'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'psk2'
        option key 'passpasspasspasspasspass'
		
=========================================================================================

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'
        list rebind_domain 'free.aero2.net.pl'
        option confdir '/tmp/dnsmasq.d'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'
		
=========================================================================================

root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  macmacmacmacmacmac
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  macmacmacmacmacmac
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  macmacmacmacmacmac
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

=========================================================================================

root@OpenWrt:~# ifstatus wan | grep address
                "addresses",
        "ipv4-address": [
                        "address": "192.168.18.2",
        "ipv6-address": [
                "ipv4-address": [
                "ipv6-address": [

to which device the wan is connected to?
are you using as wired repeater or main router?
is same behaviour seen in wired pc or only in wifi connected devices?
does 2.4 ghz and 5 ghz network signal weak/ what is the rssi?

So it is clear that you have another router upstream of the OpenWrt device.

With that in mind, when you connect to wifi and try to reach 192.168.1.1, are you doing this by connecting to the SSID called "OpenWrt" or are you connecting to the wifi of the upstream router?

My connection: the signal from the operator comes via a coaxial cable to the operator's modem (which also has wifi, but deactivated because I didn't need to use it). Redmi AX6000 is connected to it via LAN1. I connected an old router to LAN2 (I have my smart home configured on it - Aqara, Xiaomi. It will take me a long time to transfer it to the new one, so for now it works in parallel).

So, let's go back to the initial problem... you said you cannot login to the OpenWrt router when connected to wifi. Is that still an issue?

If so, please check the IP address of the device you are using while you attempt to make that connection (phone, computer, tablet) and report that here.