[SOLVED] Rebooted WE826, dropped connectivity

Hi all,

Just installed OpenWRT on a new WE826 device.

The current setup is:

House Modem -> House Router -> WE826 -> Laptop
All connects are via ethernet.

After the install I was able to connect to the internet from my laptop. I updated the wifi settings on WE826 and rebooted and now have lost all connectivity from the laptop or WE826 to the internet. Pings, Traceroute etc fail now.
When I go to the diagnostics page at:
Network -> Diagnostics -> Ping
I get "ping: Bad Address : whateverDomain.com"

The house router's IP is: 192.168.1.1
The WAN of WE826 has been statically assigned 192.168.1.105 (from house router)
The LAN of WE826 uses 192.168.1.1 as its router.
The IP of my laptop connected to WE826 is: 192.168.1.10

If I connect any other devices to the WE826 they can all see each other and talk to each other + router. Just nothing can access the internet.

ifconfig

br-lan    Link encap:Ethernet  HWaddr 78:A3:51:41:B3:74
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::7aa3:51ff:fe41:b374/64 Scope:Link
          inet6 addr: fd2e:a434:5fa7::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2807 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2698 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:327171 (319.5 KiB)  TX bytes:487972 (476.5 KiB)

eth0      Link encap:Ethernet  HWaddr 78:A3:51:41:B3:74
          inet6 addr: fe80::7aa3:51ff:fe41:b374/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5647 errors:0 dropped:1 overruns:0 frame:0
          TX packets:2743 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1108694 (1.0 MiB)  TX bytes:514972 (502.9 KiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr 78:A3:51:41:B3:74
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2807 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2698 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:327171 (319.5 KiB)  TX bytes:487972 (476.5 KiB)

eth0.2    Link encap:Ethernet  HWaddr 78:A3:51:41:B3:75
          inet addr:192.168.1.105  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::7aa3:51ff:fe41:b375/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2819 errors:0 dropped:155 overruns:0 frame:0
          TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:676505 (660.6 KiB)  TX bytes:4311 (4.2 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1328 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1328 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:112193 (109.5 KiB)  TX bytes:112193 (109.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 78:A3:51:41:B3:74
          inet6 addr: fe80::7aa3:51ff:fe41:b374/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:758 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:66700 (65.1 KiB)

route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0.2
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0.2
192.168.1.1 0.0.0.0 255.255.255.255 UH 0 0 0 eth0.2

/etc/config# cat network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2e:a434:5fa7::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '78:a3:51:41:b3:74'

config interface 'wan'
	option ifname 'eth0.2'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option proto 'dhcp'
	option hostname 'TwiML'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '78:a3:51:41:b3:75'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

root@LEDE:/etc/config# cat firewall
config defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT
# Uncomment this line to disable ipv6 rules
# option disable_ipv6 1

  config zone
  	option name		lan
  	list   network		'lan'
  	option input		ACCEPT
  	option output		ACCEPT
  	option forward		ACCEPT

  config zone
  	option name		wan
  	list   network		'wan'
  	list   network		'wan6'
  	option input		REJECT
  	option output		ACCEPT
  	option forward		REJECT
  	option masq		1
  	option mtu_fix		1

  config forwarding
  	option src		lan
  	option dest		wan

  # We need to accept udp packets on port 68,

  config rule
  	option name		Allow-DHCP-Renew
  	option src		wan
  	option proto		udp
  	option dest_port	68
  	option target		ACCEPT
  	option family		ipv4

  # Allow IPv4 ping
  config rule
  	option name		Allow-Ping
  	option src		wan
  	option proto		icmp
  	option icmp_type	echo-request
  	option family		ipv4
  	option target		ACCEPT

  config rule
  	option name		Allow-IGMP
  	option src		wan
  	option proto		igmp
  	option family		ipv4
  	option target		ACCEPT

  # Allow DHCPv6 replies

  config rule
  	option name		Allow-DHCPv6
  	option src		wan
  	option proto		udp
  	option src_ip		fc00::/6
  	option dest_ip		fc00::/6
  	option dest_port	546
  	option family		ipv6
  	option target		ACCEPT

  config rule
  	option name		Allow-MLD
  	option src		wan
  	option proto		icmp
  	option src_ip		fe80::/10
  	list icmp_type		'130/0'
  	list icmp_type		'131/0'
  	list icmp_type		'132/0'
  	list icmp_type		'143/0'
  	option family		ipv6
  	option target		ACCEPT

  # Allow essential incoming IPv6 ICMP traffic
  config rule
  	option name		Allow-ICMPv6-Input
  	option src		wan
  	option proto	icmp
  	list icmp_type		echo-request
  	list icmp_type		echo-reply
  	list icmp_type		destination-unreachable
  	list icmp_type		packet-too-big
  	list icmp_type		time-exceeded
  	list icmp_type		bad-header
  	list icmp_type		unknown-header-type
  	list icmp_type		router-solicitation
  	list icmp_type		neighbour-solicitation
  	list icmp_type		router-advertisement
  	list icmp_type		neighbour-advertisement
  	option limit		1000/sec
  	option family		ipv6
  	option target		ACCEPT

  # Allow essential forwarded IPv6 ICMP traffic
  config rule
  	option name		Allow-ICMPv6-Forward
  	option src		wan
  	option dest		*
  	option proto		icmp
  	list icmp_type		echo-request
  	list icmp_type		echo-reply
  	list icmp_type		destination-unreachable
  	list icmp_type		packet-too-big
  	list icmp_type		time-exceeded
  	list icmp_type		bad-header
  	list icmp_type		unknown-header-type
  	option limit		1000/sec
  	option family		ipv6
  	option target		ACCEPT

  config rule
  	option name		Allow-IPSec-ESP
  	option src		wan
  	option dest		lan
  	option proto		esp
  	option target		ACCEPT

  config rule
  	option name		Allow-ISAKMP
  	option src		wan
  	option dest		lan
  	option dest_port	500
  	option proto		udp
  	option target		ACCEPT

  # include a file with users custom iptables rules
  config include
  	option path /etc/firewall.user

Any ideas whats died?
Thanks!
Mathew

The DNS and gateway must be set in the lan section of /etc/config/network for pinging etc from the WE826 to go through the main router.
Turn off the DHCP server in the WE826 so your laptop doesn't get served improper settings. The only DHCP should be from the main router, so the gateway is pointed at the main router.

Yes, I do...you cannot use 192.168.1.0/24 subnet on the WAN and LAN side of the router. Since they are the same network, the router doesn't have a logical reason to route anything. Hence, you have no connectivity.

Try changing the LAN on the WE826 to something different like 192.168.2.0/24, this should help.

Instant fix!
Thanks very much for your help.

1 Like

Which one fixed it???

Apologies, I thought the reply would be threaded.
The fix was implemented by changing the LAN settings to: 192.168.2.0/24

1 Like