[solved] RB-912UAG-5HPND doesn't upgrade with sysupgrade using either snapshot/17.01.1

Hi, need some help here...

Have an rb-912uag-5hpnd which runs OpenWRT fine. But, now attempting to upgrade to LEDE and it doesn't want to upgrade using sysupgrade. Once executing sysupgrade, it exits fast and restarts... almost immediately it spontaneous attempts a netboot. As there's no console for boot, I am a bit in the dark as to what is happening at boot time.
The serial console next to SIM slot only shows console when kernel is loading, so post boot... doesn't help a lot.

Steps I performed to attempt to upgrade to LEDE

  1. Used lede-ar71xx-mikrotik-vmlinux-initramfs.elf from multiple releases now: snapshot, 17.01.1 to boot from network.
  2. As it's an 128 MB NAND, I've used nand-large-squashfs-sysupgrade.bin for sysupgrade

When I remove network cable directly after sysupgrade, it restarts and all LEDs get lit and remain lit.
Can anybody confirm that sysupgrade works? I've read that upgrade path has changed, but it doesn't work (for my board).

Any help would be very appreciated!

Already solved it with another thread that I found: https://www.mail-archive.com/lede-dev@lists.infradead.org/msg06759.html

When sysupgrade fails, than first use an older OpenWRT initramfs image to boot from network.
Erase MTD5, Mount MTD5 (kernel) (YAFFS) and copy LEDE kernel into it.
Reboot, it should come up with LEDE.

Subsequent sysupgrade from LEDE seem to work fine. At least, for me it now did...