[SOLVED] Raspberry Pi 2 Model B Rev 1.1 - New install, wireless is missing

Hello, I am familiar with older openwrt versions. Everything used to work on that same hardware, but I have just installed 18.06.1 and I don't get how wireless works.

I have installed it on a Raspberry Pi 2 Model B Rev 1.1, kernel version is 4.9.120. I have tried to plug various USB wifi antennas, all are recognized, dmesg shows them, I can't remember the firmware right now but I have them because they are supported and have always worked.

I can't see the wireless menu in luci, and I have no /etc/config/wireless and iw list does not report anything.

Is it something I missed with 18.06.1 or is there an actual issue? Can I do something to try to understand what's wrong? I have seen similar messages but failed to find a solution.

thanks for your help.

Have you tried running the wifi config command first?

thanks, yes I tried that first with no output.

Does the wireless interface exist when you run ifconfig -a ?
Is the module loaded?

I had installed ath9k-htc-firmware from System -> Software. But apparently that was not the right thing to do. It went a lot better after doing opkg install kmod-ath9k-htc kmod-ath9k-common
Now I can see the device.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.